Bug 1935626 - FTBFS with PHP 8
Summary: FTBFS with PHP 8
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: ming
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Orphan Owner
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/bui...
Whiteboard:
: 1935863 1943077 (view as bug list)
Depends On: 1934995
Blocks: F35FTBFS F35FailsToInstall 1942967
TreeView+ depends on / blocked
 
Reported: 2021-03-05 10:02 UTC by Remi Collet
Modified: 2021-06-17 00:04 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-06-17 00:04:57 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github libming libming issues 217 0 None open port to PHP 8.x 2021-04-04 23:03:57 UTC

Description Remi Collet 2021-03-05 10:02:05 UTC
See https://fedoraproject.org/wiki/Changes/php80

Related to swig bug #1934995

Comment 1 Jitka Plesnikova 2021-03-23 07:52:31 UTC
Swig was updated to support PHP 8, but it does not solve the build issue.

The failing code is not regenerated by new swig.

Comment 2 Dominik 'Rathann' Mierzejewski 2021-03-24 11:06:55 UTC
*** Bug 1935863 has been marked as a duplicate of this bug. ***

Comment 3 Miro Hrončok 2021-03-31 11:55:29 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 4 Dominik 'Rathann' Mierzejewski 2021-04-04 23:04:42 UTC
Reported upstream. I don't have enough expertise to port the code to PHP8.

Comment 5 Dominik 'Rathann' Mierzejewski 2021-04-15 13:55:02 UTC
*** Bug 1943077 has been marked as a duplicate of this bug. ***

Comment 6 Miro Hrončok 2021-05-04 22:34:49 UTC
This package has been orphaned.

You can pick it up at https://src.fedoraproject.org/rpms/ming by clicking button "Take". If nobody picks it up, it will be retired and removed from a distribution.

Comment 7 Fedora Admin user for bugzilla script actions 2021-05-05 00:15:37 UTC
This package has changed maintainer in Fedora. Reassigning to the new maintainer of this component.

Comment 8 Miro Hrončok 2021-06-17 00:04:57 UTC
Automation has figured out the package is retired in rawhide.

If you like it to be unretired, please open a ticket at https://pagure.io/releng/new_issue?template=package_unretirement


Note You need to log in before you can comment on or make changes to this bug.