Bug 1935629 - python-animatplot: FTBFS in Fedora rawhide
Summary: python-animatplot: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-animatplot
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Elliott Sales de Andrade
QA Contact: Fedora Extras Quality Assurance
URL: https://koschei.fedoraproject.org/pac...
Whiteboard:
: 1968891 (view as bug list)
Depends On:
Blocks: F35FTBFS F35FailsToInstall PYTHON3.10 1969173 1979353 1988077
TreeView+ depends on / blocked
 
Reported: 2021-03-05 10:11 UTC by Tomáš Hrnčiar
Modified: 2021-08-02 02:42 UTC (History)
4 users (show)

Fixed In Version: python-animatplot-0.4.1-11.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-02 02:42:20 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github t-makaro animatplot issues 58 0 None open BunchOfFiles writer incompatible with matplotlib-3.4 2021-07-11 20:38:24 UTC

Description Tomáš Hrnčiar 2021-03-05 10:11:32 UTC
Description of problem:
Package python-animatplot fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.4.1-9.fc34

Steps to Reproduce:
koji build --scratch f35 python-animatplot-0.4.1-9.fc34.src.rpm

Additional info:
This package is tracked by Koschei. See:
https://koschei.fedoraproject.org/package/python-animatplot

Comment 1 Miro Hrončok 2021-06-04 20:15:48 UTC
This is a mass-posted update. Sorry if it is not 100% accurate to this bugzilla.


The Python 3.10 rebuild is in progress in a Koji side tag. If you manage to fix the problem, please commit the fix in the rawhide branch, but don't build the package in regular rawhide.

You can either build the package in the side tag, with:

    $ fedpkg build --target=f35-python

Or you can the build and we will eventually build it for you.

Note that the rebuild is still in progress, so not all (build) dependencies of this package might be available right away.

Thanks.

See also https://fedoraproject.org/wiki/Changes/Python3.10

If you have general questions about the rebuild, please use this mailing list thread: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org/thread/G47SGOYIQLRDTWGOSLSWERZSSHXDEDH5/

Comment 2 Miro Hrončok 2021-06-07 23:00:09 UTC
The f35-python side tag has been merged to Rawhide. From now on, build as you would normally build.

Comment 3 Miro Hrončok 2021-06-08 11:21:44 UTC
*** Bug 1968891 has been marked as a duplicate of this bug. ***

Comment 4 Miro Hrončok 2021-06-15 20:25:58 UTC
Hello,

This is the first reminder (step 3 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 5 Miro Hrončok 2021-07-07 11:23:36 UTC
Hello,

This is the second reminder (step 4 from https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/#_package_removal_for_long_standing_ftbfs_and_fti_bugs).

If you know about this problem and are planning on fixing it, please acknowledge so by setting the bug status to ASSIGNED. If you don't have time to maintain this package, consider orphaning it, so maintainers of dependent packages realize the problem.

Comment 6 Fedora Release Engineering 2021-07-11 04:22:38 UTC
Dear Maintainer,

your package has an open Fails To Build From Source bug for Fedora 35.
Action is required from you.

If you can fix your package to build, perform a build in koji, and either create
an update in bodhi, or close this bug without creating an update, if updating is
not appropriate [1]. If you are working on a fix, set the status to ASSIGNED to
acknowledge this. If you have already fixed this issue, please close this Bugzilla report.

Following the policy for such packages [2], your package will be orphaned if
this bug remains in NEW state more than 8 weeks (not sooner than 2021-04-30).

A week before the mass branching of Fedora 36 according to the schedule [3],
any packages not successfully rebuilt at least on Fedora 34 will be
retired regardless of the status of this bug.

[1] https://docs.fedoraproject.org/en-US/fesco/Updates_Policy/
[2] https://docs.fedoraproject.org/en-US/fesco/Fails_to_build_from_source_Fails_to_install/
[3] https://fedorapeople.org/groups/schedule/f-36/f-36-key-tasks.html

Comment 7 Elliott Sales de Andrade 2021-07-11 20:38:24 UTC
There's https://src.fedoraproject.org/rpms/python-animatplot/pull-request/1 but unfortunately still have to worry about https://github.com/t-makaro/animatplot/issues/58

Comment 8 david08741 2021-07-28 08:45:47 UTC
I think the last two commits at https://github.com/boutproject/animatplot-ng/commits/main
should fix the FTBFS.

They change binary files, thus they cannot be added as patches.

Comment 9 Miro Hrončok 2021-07-28 10:54:37 UTC
If you use:

BuildRequires: git-core
...
%prep
%autosetup -S git_am

You can use git patches with binary files.

Comment 10 Elliott Sales de Andrade 2021-08-02 02:42:20 UTC
Thanks for the patches; this is now fixed.


Note You need to log in before you can comment on or make changes to this bug.