Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: when migration fail and shows up a warning in the "last state" of migplan. After fixed the issue and then execute migration or stage, migration or stage succeeded but the warning still is there Version-Release number of selected component (if applicable): MTC 1.4.2 registry.redhat.io/rhmtc/openshift-migration-ui-rhel8@sha256:2d184b121f91f28cc47015ec8da676c895885d4369177812c387464d451fa353 How reproducible: always Steps to Reproduce: 1. In source cluster. Create a namespace $ oc new-project ocp-37723-partialfailbackup 2. In source cluster. Build an image $ oc new-build -D $'FROM centos:7\nRUN yum install -y httpd' -n ocp-37723-partialfailbackup 3. In source cluster. Disable the source cluster's internal registry. If OCP3X: $ oc scale --replicas=0 dc docker-registry -n default If OCP4X: $ oc patch configs.imageregistry.operator.openshift.io cluster -p '{"spec":{"managementState": "Removed"} }' --type='merge'; 4 Run the direct migration It will report a warning , such like "DirectImageMigration (dim): openshift-migration/e11c4350-7d9f-11eb-94b8-69a024095fc1-hn66m failed. See dim Status.Errors for details." And The last stage of the migplan on UI is showing up a warning "Migration completed with warnings" 5. Enable the source cluster's internal registry. If OCP3X: $ oc scale --replicas=1 dc docker-registry -n default If OCP4X: oc patch configs.imageregistry.operator.openshift.io cluster -p '{"spec":{"managementState": "Managed"} }' --type='merge'; 6. Run the direct migration again and migration finished successfully Actual results: The last stage of the migplan on UI still is showing up a warning "Migration completed with warnings" Expected results: The warning should be disappeared as the the last migration finished successfully Additional info:
Unable to reproduce
Fixed in https://github.com/konveyor/mig-ui/pull/1114
Verified using MTC 1.5.0 openshift-migration-rhel7-operator@sha256:00e77706ca22bcb557d13c16822180fc877e6ea1639a72fda8eb9f5488b039a2 - name: MIG_CONTROLLER_REPO value: openshift-migration-controller-rhel8@sha256 - name: MIG_CONTROLLER_TAG value: 7f657df15e9514df4ef42da3431f558a19b8d3233a2ef1222cd8e27793c93816 - name: MIG_UI_REPO value: openshift-migration-ui-rhel8@sha256 - name: MIG_UI_TAG value: bda1959e1f44170905499b304ce28f9f95ee1841b0dc29f9a9e2790d0dd0bd71 We can still see the migplan marked with warnings and saying "Migration completed with warnings" even if the last migmigration execution went fine and without problems. We move the BZ to ASSIGNED.
Is this is a release blocker bug as we are in the blockers only mode now
Verified using MTC 1.5.0 openshift-migration-rhel7-operator@sha256:aeda48329c452082e03052d7bd2fc71e9762469540cdb60eb4d4004418f2a0c7 - name: MIG_CONTROLLER_REPO value: openshift-migration-controller-rhel8@sha256 - name: MIG_CONTROLLER_TAG value: 7f109e3ac03acf8f1524033bbbc10b987eeaad81856a3bc03851e1b571e8a9c7 - name: MIG_UI_REPO value: openshift-migration-ui-rhel8@sha256 - name: MIG_UI_TAG value: e7f42e2a120aea489fd083428452049a835910971cef27a5b7e5dded153f0dae The migration plan shows no warning anymore when the a migration with warnings has been rollbacked and then executed properly. Moved to VERIFIED.
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. For information on the advisory (Migration Toolkit for Containers (MTC) image release advisory 1.5.0), and where to find the updated files, follow the link below. If the solution does not work for you, open a new bug report. https://access.redhat.com/errata/RHEA-2021:2929