Bug 1935781 - systemd-nspawn -U faills
Summary: systemd-nspawn -U faills
Keywords:
Status: CLOSED DUPLICATE of bug 1913806
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: systemd
Version: 8.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: systemd-maint
QA Contact: Frantisek Sumsal
URL:
Whiteboard:
: 1935751 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-05 14:22 UTC by František Hrdina
Modified: 2021-03-05 15:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-05 15:10:50 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)

Description František Hrdina 2021-03-05 14:22:19 UTC
Description of problem:
Connection to container with systemd-nspawn -U fails on rhel8.4

Version-Release number of selected component (if applicable):
systemd-239-44.el8.x86_64
systemd-container-239-44.el8.x86_64

How reproducible:
always


Steps to Reproduce:
yum install mock
mock --rootdir /var/lib/machines/test --init
cd /var/lib/machines/test/
systemd-nspawn  -U

Actual results:
Spawning container test on /var/lib/machines/test
Press ^] three times within 1s to kill container.
Selected user namespace base 202244096 and range 65536.
Failed to mount cgroup on /sys/fs/cgroup/memory (MS_NOSUID|MS_NODEV|MS_NOEXEC "memory"): Operation not permitted
Child died too early.

Expected results: 
Spawning container test on /var/lib/machines/test.
Press ^] three times within 1s to kill container.
Selected user namespace base 202244096 and range 65536.



Additional info:

Comment 1 Petr Sklenar 2021-03-05 14:25:17 UTC
*** Bug 1935751 has been marked as a duplicate of this bug. ***

Comment 3 David Tardon 2021-03-05 15:10:50 UTC

*** This bug has been marked as a duplicate of bug 1913806 ***


Note You need to log in before you can comment on or make changes to this bug.