Bug 193586 - SATA will not wake from suspend to RAM
Summary: SATA will not wake from suspend to RAM
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
(Show other bugs)
Version: 4.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: David Milburn
QA Contact: Brian Brock
URL: https://bugzilla.redhat.com/bugzilla/...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-30 19:47 UTC by Erik Webb
Modified: 2009-08-20 17:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-20 17:57:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 169201 None None None Never

Description Erik Webb 2006-05-30 19:47:19 UTC
This is a well-established ticket with a working (unsupported) patch for Fedora
Core 4. I could not find a similar ticket for RHEL4.

From linked Bugzilla report:
"Various thinkpads with SATA controllers (actually, they have PATA hard drives
with PATA to SATA adapters, aparently) cannot recover from suspend to RAM due to
 lack of power management support in SATA."

Comment 1 Marcelo Giles 2006-11-15 03:30:02 UTC
I'm having this problem with an IBM Thinkpad T43 and RHEL 4 U4 (2.6.9-42).

Machine suspends to RAM, but when waking stops responding with the kind of
console messages described in BZ#169201:

kernel: journal commit I/O error 
end_request: I/O error, dev sda, sector 121135224
sd 0:0:0:0: SCSI error return code: 0x4000
etc.

Any news on this issue?

Comment 2 David Milburn 2009-08-20 17:57:28 UTC
I don't have a platform to verify, but it looks like all the PM hooks
exist in RHEL4 U8, closing this BZ, please re-open if necessary.


Note You need to log in before you can comment on or make changes to this bug.