Bug 193602 - qt4: useless debuginfo package
Summary: qt4: useless debuginfo package
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: qt4   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 193601
TreeView+ depends on / blocked
 
Reported: 2006-05-30 21:27 UTC by Ville Skyttä
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-27 16:07:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ville Skyttä 2006-05-30 21:27:25 UTC
qt4's debuginfo package is useless:

$ rpm -qlp
http://fedoraproject.org/extras/development/i386/debug/qt4-debuginfo-4.1.3-5.fc6.i386.rpm
(contains no files)

More info: http://fedoraproject.org/wiki/Packaging/Debuginfo

Comment 1 Rex Dieter 2006-06-08 13:02:02 UTC
Looks like qmake is to blame, it uses (by default):
QMAKE_STRIP             = strip
QMAKE_STRIPFLAGS_LIB    += --strip-unneeded

So, at least for the initial qt4 (rpm) build, I'll have to override these
(default) values.

Comment 2 Rex Dieter 2006-06-08 20:38:05 UTC
This will also affect all(most?) apps/libraries built against qt4 using qmake. 
They will also end up with useless -debuginfo rpms.  For example, see
texmaker-debuginfo-1.3 currently in Extras.

2 options:
(1) Disable QT_STRIP (unconditionally).  patch mkspecs/%{platform}/qmake.conf:
QMAKE_STRIP = /bin/true

(2) Create a new QMAKESPEC, named, say, debuginfo(*), cloning mkspecs/default to
mkspecs/debuginfo, and then modify mkspecs/debuginfo/qmake.conf to include instead:
QMAKE_STRIP = /bin/true
Default behavior would stay the same (ie, include the ability to strip, which
matches upstream default behavior), while allowing a different QMAKESPEC for
packagers who want/need (useful) -debuginfo rpms.  This would require packagers
to use:
qmake4 -spec debuginfo
and/or set
export QMAKESPEC=debuginfo
before running qmake4.

(*) debuginfo is the first name I came up with.  Can use any new/unique name here.

Comment 3 Rex Dieter 2006-06-08 20:40:37 UTC
It appears (un)setting
QMAKE_STRIP = 
works too.

Comment 4 Michael Möllney 2006-06-22 22:12:15 UTC
But where to find the qt4 debug libraries.

using in the qt .pro file:
CONFIG += debug

makes the linker complain about:
/usr/bin/ld: cannot find -lQtGui_debug

I can't find the package containing:
libQtGui_debug.so.4.1.3
and analog files.
Shouldn't this be also in this debuginfo???

or is the qt4-devel the right rpm?

Comment 5 Rex Dieter 2006-06-22 22:15:10 UTC
qt4 as-is isn't built with debug libraries (only ./configure --release).  If you
want/need that, please file another report.

Comment 6 Rex Dieter 2006-06-27 16:07:10 UTC
Reclosing...

Comment 7 Rex Dieter 2006-06-27 16:18:57 UTC
Re: comment #4 and comment #5, see bug #196513


Note You need to log in before you can comment on or make changes to this bug.