Bug 193606 - glibc-kernheaders dropped asmmacro.h
glibc-kernheaders dropped asmmacro.h
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glibc-kernheaders (Show other bugs)
rawhide
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: David Woodhouse
Brian Brock
:
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-05-30 18:28 EDT by Aron Griffis
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-30 18:46:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aron Griffis 2006-05-30 18:28:11 EDT
Recent glibc-kernheaders has dropped /usr/include/asm/asmmacro.h.  This file is
needed for xen compilation on ia64.

$ rpm -qpl glibc-kernheaders-3.0-7.ia64.rpm | grep asmmacro
/usr/include/asm/asmmacro.h

$ rpm -qpl glibc-kernheaders-3.0-36.ia64.rpm | grep asmmacro
(nothing)
Comment 1 David Woodhouse 2006-05-30 18:46:19 EDT
That's because it's a kernel _PRIVATE_ header. Unless I'm mistaken, there is no
part of the kernel<->user ABI described in it.

The kernel's private headers are not a library provided for userspace. Please
reopen if there's anything in asmmacro.h that you actually have any business
accessing, and be very specific about what it is that you need and why.
Comment 2 Aron Griffis 2006-05-30 19:23:12 EDT
Thanks David.  Looks like this dependency was recently fixed in
xen-ia64-unstable upstream.  Sorry for the bother.

Note You need to log in before you can comment on or make changes to this bug.