Bug 193607 - dhcp-options(5) man page is missing
dhcp-options(5) man page is missing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dhcp (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-30 20:15 EDT by Don Buchholz
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version: FC5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-21 22:13:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Don Buchholz 2006-05-30 20:15:54 EDT
Description of problem:
dhcp.conf(5) references a dhcp-options(5) man page, but that page is
not on the system.

Version-Release number of selected component (if applicable):
3.0.2-34.FC4

How reproducible:
Always.

Steps to Reproduce:
1.  man dhcp-options
2.
3.
  
Actual results:
# man dhcp-options
No manual entry for dhcp-options


Expected results:
.. to see a page

Additional info:
Comment 1 Jason Vas Dias 2006-05-31 10:31:08 EDT
Actually, the dhcp-options man-page is shipped as part of the 'dhclient' RPM -
not sure why - I agree it makes more sense to ship it as part of the 'dhcp'
RPM, but then it applies to both the server and client, since you can
declare options both in dhcpd.conf and in dhclient.conf. Perhaps the 
best solution would be to ship the same man-page as 'dhcpd-options' in
the dhcp package, and as 'dhclient-options' in the dhclient package.
This issue will be resolved in the next release of DHCP, but does not
warrant a package respin.


Comment 2 Don Buchholz 2006-05-31 11:53:36 EDT
Thanks.  I knew I'd seen the page before -- but couldn't find it yesterday on my
RHEL-3, RHEL-4, FC3, FC4, or FC5 systems.  I did find one [in 'dhcp-2.0pl5-8']
on one of the Red Hat 7.3 systems!  (But it *is* a bit dated.)

I'll install the 'dhclient' package on the DHCP server so I have access to the
man page, but I do think that your idea of shipping the same page twice (as
'dhcpd-options' and 'dhclient-options') is probably the best way to solve the
issue, as RPM won't allow us to associate the same file with two different packages.
Comment 3 Bill Nottingham 2006-09-21 22:13:51 EDT
Closing bugs in MODIFIED state from prior Fedora releases. If this bug persists
in a current Fedora release (such as Fedora Core 5 or later), please reopen and
set the version appropriately.

Note You need to log in before you can comment on or make changes to this bug.