Bug 1936419 - FFU 13-16.1 Upgrade: Leapp upgrade on ceph nodes failing as leap parameters try to enable the Fast datapath repo
Summary: FFU 13-16.1 Upgrade: Leapp upgrade on ceph nodes failing as leap parameters ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 16.1 (Train)
Hardware: x86_64
OS: All
high
high
Target Milestone: z6
: 16.1 (Train on RHEL 8.2)
Assignee: Giulio Fidente
QA Contact: Sergii Golovatiuk
URL:
Whiteboard:
: 1939419 (view as bug list)
Depends On:
Blocks: 1939419
TreeView+ depends on / blocked
 
Reported: 2021-03-08 12:59 UTC by Shravan Kumar Tiwari
Modified: 2021-08-20 12:25 UTC (History)
10 users (show)

Fixed In Version: openstack-tripleo-heat-templates-11.3.2-1.20210324233518.29a02c1.el8ost
Doc Type: Bug Fix
Doc Text:
This update fixes a configuration problem that caused Leapp upgrades to stop and fail while executing on a CephStorage node. + Previously, CephStorage nodes were incorrectly configured to consume OpenStack highavailability, advanced-virt, and fast-datapath repos during Leapp upgrades. + Now `UpgradeLeappCommand` options is configurable on a per-node basis, and uses the correct default for CephStorage nodes, and Leapp upgrades succeed for CephStorage nodes.
Clone Of:
: 1939419 (view as bug list)
Environment:
Last Closed: 2021-05-26 13:51:50 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1915067 0 None None None 2021-03-09 16:14:32 UTC
OpenStack gerrit 781056 0 None MERGED Make UpgradeInitCommand and UpgradeLeapp{ToRemove,ToInstall,CommandOptions} per-role 2021-05-25 20:20:11 UTC
Red Hat Bugzilla 1923887 1 high CLOSED virt:8.2 module not available in ceph subscription makes fail the upgrade/update 2021-05-26 13:55:35 UTC
Red Hat Product Errata RHBA-2021:2097 0 None None None 2021-05-26 13:52:24 UTC

Internal Links: 1938198

Description Shravan Kumar Tiwari 2021-03-08 12:59:55 UTC
Description of problem:


Version-Release number of selected component (if applicable):
RHOSP13 to 16.1 FFU

Controllers upgraded to 16.1.
Leap upgrade on ceph node is failing


- Perform upgrade doc of 13 to 16.1 and perform the leapp upgrade in ceph node and ceph nodes fail with following error.



- leapp_upgrade.log shows that leapp is setting parameter to get fast datapath repo:

2021-02-18 15:36:33.33  DEBUG    PID: 17650 leapp.workflow.TargetTransactionFactsCollection.target_userspace_creator: External command has started: ['systemd-nspawn', '--register=no', '--quiet', '-D', '/var/lib/leapp/scratch/mounts/root_/system_overlay', '--bind=/etc/hosts:/etc/hosts', '--setenv=LEAPP_NO_RHSM=0', '--setenv=LEAPP_EXPERIMENTAL=0', '--setenv=LEAPP_COMMON_TOOLS=:/etc/leapp/repos.d/system_upgrade/el7toel8/tools', '--setenv=LEAPP_COMMON_FILES=:/etc/leapp/repos.d/system_upgrade/el7toel8/files', '--setenv=LEAPP_ENABLE_REPOS=rhel-8-for-x86_64-baseos-eus-rpms,rhel-8-for-x86_64-appstream-eus-rpms,fast-datapath-for-rhel-8-x86_64-rpms,ansible-2.9-for-rhel-8-x86_64-rpms', '--setenv=LEAPP_UNSUPPORTED=0', '--setenv=LEAPP_EXECUTION_ID=aa7b751f-69a4-48bb-b861-9969f7f289e7', '--setenv=LEAPP_HOSTNAME=oscar11dir001.mgt.lab.corp', 'ln', '-s', '/etc/rhsm', '/etc/rhsm-host']


- The upgrade logs shows the following failure:
2021-03-08 08:10:50,794 p=380209 u=mistral n=ansible | fatal: [oscar11cep001]: FAILED! => {"changed": true, "cmd": " leapp upgrade --debug --enablerepo rhel-8-for-x86_64-baseos-eus-rpms --enablerepo rhel-8-for-x86_64-appstream-eus-rpm    s --enablerepo fast-datapath-for-rhel-8-x86_64-rpms\n", "delta": "0:02:30.726551", "end": "2021-03-08 08:10:49.945347", "msg": "non-zero return code", "rc": 1, "start": "2021-03-08 08:08:19.218796", "stderr": "2021-03-08 08:08:20.975     INFO     PID: 70463 leapp: Logging has been initialized\n2021-03-08 08:08:20.995 INFO     PID: 70463 leapp.repository.common: A new repository 'common' is initialized at /etc/leapp/repos.d/common\n2021-03-08 08:08:20.997 DEBUG    PID:     70463 leapp.repository.common: Scanning path /etc/leapp/repos.d/common\n2021-03-08 08:08:20.999 DEBUG    PID: 70463 leapp.repository.common: Adding topic - topics/systeminfo.py\n2021-03-08 08:08:21.2   INFO     PID: 70463 leapp.repos    itory.system_upgrade_el7toel8: A new repository 'system_upgrade_el7toel8' is initialized at /etc/leapp/repos.d/system_upgrade/el7toel8\n2021-03-08 08:08:21.3


Following are the repos those are being included as part of upgrade process.

"===================================
=========================", "                       END OF ERRORS        

On the ceph node itself we see following repos available
2021-03-08 08:10:49.450 INFO     PID: 76725 leapp.workflow.TargetTransactionFactsCollection.target_userspace_creator: The following repoids are available through RHSM:
    - CLOUD_CLOUD8_CLOUD8
    - CLOUD_EPEL_EPEL8
    - CLOUD_HP_hpe-el8-gen10-current
    - ansible-2.9-for-rhel-8-x86_64-rpms
    - openstack-16.1-deployment-tools-for-rhel-8-x86_64-rpms
    - rhceph-4-mon-for-rhel-8-x86_64-rpms
    - rhceph-4-osd-for-rhel-8-x86_64-rpms
    - rhceph-4-tools-for-rhel-8-x86_64-rpms
    - rhel-8-for-x86_64-appstream-rpms
    - rhel-8-for-x86_64-baseos-rpms
    - satellite-tools-6.8-for-rhel-8-x86_64-rpms


Actual results:


Expected results:
FDP repo is not provided by ceph/rhel repo and it should not be called up by leapp during upgrade 

Additional info:

Comment 8 Vlada Grosu 2021-03-16 12:17:24 UTC
*** Bug 1939419 has been marked as a duplicate of this bug. ***

Comment 9 Jesse Pretorius 2021-03-16 17:52:16 UTC
*** Bug 1939419 has been marked as a duplicate of this bug. ***

Comment 27 errata-xmlrpc 2021-05-26 13:51:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat OpenStack Platform 16.1.6 bug fix and enhancement advisory), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:2097


Note You need to log in before you can comment on or make changes to this bug.