Bug 193644 - Problem compiling
Summary: Problem compiling
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc   
(Show other bugs)
Version: 5
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-05-31 11:34 UTC by Victor Lorenz
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-31 14:55:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Victor Lorenz 2006-05-31 11:34:15 UTC
Description of problem:

Trying to compile  Kmymoney2 (source from CVS )
Version-Release number of selected component (if applicable):
qt-3.3-kde

How reproducible:

Tried to compile several times
Steps to Reproduce:
1.run "make -f Makefile.dist"
2.run "./configure --prefix=/usr"
3.run "make"
  
Actual results:
error msg:
then mv -f ".deps/mymoneystoragexml.Tpo" ".deps/mymoneystoragexml.Po"; 
else rm -f ".deps/mymoneystoragexml.Tpo"; exit 1; fi
/usr/lib/qt-3.3/include/qvaluelist.h: In 
destructor âQValueListPrivate<T>::~QValueListPrivate() [with T = 
MyMoneyReport]â:
/usr/lib/qt-3.3/include/qvaluelist.h:276: internal compiler error: 
Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[5]: *** [mymoneystoragexml.o] Error 1
make[5]: Leaving directory 
`/home/victor/A_Pgms_Add/KMM2/kmymoney2/kmymoney2/mymoney/storage'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory 
`/home/victor/A_Pgms_Add/KMM2/kmymoney2/kmymoney2/mymoney'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory 
`/home/victor/A_Pgms_Add/KMM2/kmymoney2/kmymoney2'
make[2]: *** [all] Error 2
make[2]: Leaving directory 
`/home/victor/A_Pgms_Add/KMM2/kmymoney2/kmymoney2'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/victor/A_Pgms_Add/KMM2/kmymoney2'
make: *** [all] Error 2

Comment 1 Jakub Jelinek 2006-05-31 13:12:40 UTC
Is the error always on the same file, some line?
The message above suggests that it is not, in which case the reason is most
likely bad hardware.
If it is always on the same file same line, I need preprocessed source
that you can reproduce it on.

Comment 2 Victor Lorenz 2006-05-31 14:47:33 UTC
Tried compiling again and problem does appear to occur in a different place now.
As to hardware problem, assume it would be the hard drive. Is there a check
utility like "MS's scandisk"?

Comment 3 Jakub Jelinek 2006-05-31 14:55:59 UTC
Very unlikely harddisk (you'd use say /sbin/badblocks to check it).  The usual
suspects are bad CPU cooling, bad memory, or motherboard/CPU.

Comment 4 Victor Lorenz 2006-05-31 20:04:24 UTC
Was bad CPU cooling. Cleaned vents/fans etc and problem resolved. TFYH


Note You need to log in before you can comment on or make changes to this bug.