Bug 193657 - Split up tcpdump into tcpdump, libpcap and arpwatch
Split up tcpdump into tcpdump, libpcap and arpwatch
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: tcpdump (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On: 213832 213868
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-31 09:55 EDT by Robert Scheck
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 07:43:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
New tcpdump.spec (15.65 KB, application/octet-stream)
2006-06-05 09:54 EDT, Robert Scheck
no flags Details
tcpdump-3.9.4-redhat.patch obsoleting tcpdump-3.9.1-redhat.patch (894 bytes, patch)
2006-06-05 09:55 EDT, Robert Scheck
no flags Details | Diff
New libpcap.spec (15.95 KB, application/octet-stream)
2006-06-05 09:56 EDT, Robert Scheck
no flags Details
libpcap-0.9.4-redhat.patch obsoleting tcpdump-3.9.1-redhat.patch (559 bytes, patch)
2006-06-05 09:57 EDT, Robert Scheck
no flags Details | Diff
New arpwatch.spec (16.30 KB, application/octet-stream)
2006-06-05 09:58 EDT, Robert Scheck
no flags Details
Updated tcpdump.spec, no rpmlint output on x86_32 (15.76 KB, application/octet-stream)
2006-06-14 07:11 EDT, Robert Scheck
no flags Details
Updated libpcap.spec, no rpmlint output on x86_32 (16.07 KB, application/octet-stream)
2006-06-14 07:13 EDT, Robert Scheck
no flags Details
Updated arpwatch.spec, some rpmlint output on x86_32: (16.42 KB, application/octet-stream)
2006-06-14 07:14 EDT, Robert Scheck
no flags Details

  None (edit)
Description Robert Scheck 2006-05-31 09:55:45 EDT
Description of problem:
Please seperate tcpdump into three stand-alone source rpm packages: tcpdump, 
libpcap and arpwatch as it is common at Fedora Core.

Version-Release number of selected component (if applicable):
tcpdump-3.9.4-4

Actual results:
One big source rpm package having tcpdump, libpcap and arpwatch - but called 
simply tcpdump.

Expected results:
Stand-alone source rpm packages: tcpdump, libpcap and arpwatch

Additional info:
Just worked until now, but arpwatch wasn't updated since a longer time IIRC
and doesn't need to be rebuild everytime, when something else changes.

If this bug is accepted, I'm willing to work out three sane spec files in
typical Fedora Extras layout (because of the Fedora Core cleanup project).
Comment 1 Martin Stransky 2006-06-05 04:59:33 EDT
Okay, could you please provide those spec files?
Comment 2 Robert Scheck 2006-06-05 09:54:13 EDT
Created attachment 130496 [details]
New tcpdump.spec
Comment 3 Robert Scheck 2006-06-05 09:55:25 EDT
Created attachment 130497 [details]
tcpdump-3.9.4-redhat.patch obsoleting tcpdump-3.9.1-redhat.patch
Comment 4 Robert Scheck 2006-06-05 09:56:19 EDT
Created attachment 130498 [details]
New libpcap.spec
Comment 5 Robert Scheck 2006-06-05 09:57:38 EDT
Created attachment 130499 [details]
libpcap-0.9.4-redhat.patch obsoleting tcpdump-3.9.1-redhat.patch
Comment 6 Robert Scheck 2006-06-05 09:58:56 EDT
Created attachment 130500 [details]
New arpwatch.spec
Comment 7 Robert Scheck 2006-06-05 10:02:58 EDT
Martin, this is what I worked out and what is working here. Hopefully I didn't 
forget anything. At least, I dunno whether it's bugfree - I've got no mock or 
Red Hat Buildsystem here. Build requirements were adapted as far as I was able 
to reconstruct. So reviewing and questions are desired... ;-)
Comment 8 Robert Scheck 2006-06-14 07:11:47 EDT
Created attachment 130819 [details]
Updated tcpdump.spec, no rpmlint output on x86_32
Comment 9 Robert Scheck 2006-06-14 07:13:03 EDT
Created attachment 130820 [details]
Updated libpcap.spec, no rpmlint output on x86_32
Comment 10 Robert Scheck 2006-06-14 07:14:44 EDT
Created attachment 130821 [details]
Updated arpwatch.spec, some rpmlint output on x86_32:

W: arpwatch conffile-without-noreplace-flag /var/arpwatch/ethercodes.dat
W: arpwatch conffile-without-noreplace-flag /var/arpwatch/missingcodes.txt
E: arpwatch non-standard-uid /var/arpwatch/duplicates.awk pcap
E: arpwatch non-standard-gid /var/arpwatch/duplicates.awk pcap
E: arpwatch non-standard-uid /var/arpwatch/ethercodes.dat pcap
E: arpwatch non-standard-gid /var/arpwatch/ethercodes.dat pcap
E: arpwatch non-standard-uid /var/arpwatch pcap
E: arpwatch non-standard-gid /var/arpwatch pcap
E: arpwatch non-standard-uid /var/arpwatch/arp2ethers pcap
E: arpwatch non-standard-gid /var/arpwatch/arp2ethers pcap
E: arpwatch non-standard-uid /var/arpwatch/massagevendor-old pcap
E: arpwatch non-standard-gid /var/arpwatch/massagevendor-old pcap
E: arpwatch non-standard-uid /var/arpwatch/massagevendor pcap
E: arpwatch non-standard-gid /var/arpwatch/massagevendor pcap
E: arpwatch non-standard-uid /var/arpwatch/p.awk pcap
E: arpwatch non-standard-gid /var/arpwatch/p.awk pcap
E: arpwatch non-standard-uid /var/arpwatch/e.awk pcap
E: arpwatch non-standard-gid /var/arpwatch/e.awk pcap
E: arpwatch non-standard-uid /var/arpwatch/missingcodes.txt pcap
E: arpwatch non-standard-gid /var/arpwatch/missingcodes.txt pcap
E: arpwatch non-standard-uid /var/arpwatch/arp.dat pcap
E: arpwatch non-standard-gid /var/arpwatch/arp.dat pcap
E: arpwatch zero-length /var/arpwatch/arp.dat
E: arpwatch non-standard-uid /var/arpwatch/arpfetch pcap
E: arpwatch non-standard-gid /var/arpwatch/arpfetch pcap
E: arpwatch non-standard-uid /var/arpwatch/euppertolower.awk pcap
E: arpwatch non-standard-gid /var/arpwatch/euppertolower.awk pcap
E: arpwatch non-standard-uid /var/arpwatch/d.awk pcap
E: arpwatch non-standard-gid /var/arpwatch/d.awk pcap
W: arpwatch non-standard-dir-in-var arpwatch
Comment 11 Robert Scheck 2006-06-30 05:15:41 EDT
Ping?
Comment 12 Martin Stransky 2006-06-30 10:04:02 EDT
I'll apply this one in new devel cycle (i.e. for FC-7)

Note You need to log in before you can comment on or make changes to this bug.