Bug 193669 - rhn/up2date registration fails everytime if hardware profile included
rhn/up2date registration fails everytime if hardware profile included
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date (Show other bugs)
4.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-31 11:11 EDT by Robert M Williams
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 12:08:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert M Williams 2006-05-31 11:11:59 EDT
Description of problem:
rhn/up2date fails with unable to send hardware profile error
account is created on rhn server (sans hardware info), but association not made
on client
no log file created or output if using --verbose option in CLI
this failure happens 100% of attempts

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. install rhel4
2. use up2date either from firstboot or after gnome starts
3. 
  
Actual results:
failure to send hardware profile/create association on client
server account is created, but client will not connect/associate with account
created

Expected results:
send profile to server
account created
client associated with account

Additional info:
Comment 1 Robert M Williams 2006-05-31 11:22:42 EDT
system on which failure occurs is a laptop
basic specs:
processor : intel centrino 1.73GHz
video     : ATI X700 PCI-e
network   : broadcom gigabit ethernet (connection confirmed before registration
attempt)
network   : intel ipw2200bg wireless (not connected at time of this specific
attempt, but same failure when is primary network adapter)

clicking the hardware details from the registration screen, prior to
registration attemp, does display system config

problem does not occur if 'send hardware profile' de-selected prior to submission
Comment 2 Red Hat Bugzilla 2007-04-11 20:44:26 EDT
User bnackash@redhat.com's account has been closed
Comment 4 Pradeep Kilambi 2007-07-31 12:08:00 EDT
tried registering few test boxes and seems to be doing the right thing as of
latest up2date

# rpm -q up2date
up2date-4.5.5-7.el4
 

A Profile Name is a descriptive name that you choose to identify this System
Profile on the
 Red Hat Network web pages. Optionally, include a computer serial or
identification number.
 Profile name: 2.rhndev.redhat.com_

 [*] Include the following information about hardware and network:

    Version: 4AS                        CPU model: Mobile Intel(R) Pentium(R)
III CPU - M  1200MHz
   Hostname: rlx-2-22.rhndev.redhat.com CPU speed: 1199 MHz
 IP Address: 10.10.76.192                  Memory: 2027 megabytes

and registers successfully.

closing as not a bug on up2date-4.5.5-7, feel free to open it with more comments
if you think we missed any other scenerio.


Note You need to log in before you can comment on or make changes to this bug.