Bug 19367 - Failure to restart sendmail
Failure to restart sendmail
Status: CLOSED DUPLICATE of bug 20696
Product: Red Hat Linux
Classification: Retired
Component: initscripts (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-19 00:35 EDT by Jon Benson
Modified: 2014-03-16 22:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 00:36:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Benson 2000-10-19 00:35:59 EDT
When using "/etc/rc.d/init.d/sendmail restart" which is basically a stop
followed by a start it fails.

The fault can be looked at in one of two ways.

1. The stop being at fault:
It only kills the original sendmail server process and will leave other
sendmail proccess around to complete sending/receiving mail.  This is
actually desired behaviour IMHO.

This means the start process finds a sendmail process running and refuses
to start the server.


2. The start proccss being at fault:
The start process perhaps needs to pass an optional extra argument or
employ some method such that it can search for a certain instance of a
process.

Eg. in the case of sendmail the process that is relevant to the restart is
the one accepting connections which appears as follows when doing a "ps
auxww":
sendmail: accepting connections

Hence there exists the opportunity to test for a process that has both the
process name of sendmail and contains the key information "accepting
connections"

I hope this makes sense as it is certainly a feature I'd love to see fixed
as we regularly restart our mail server after various configuration
changes.
Comment 1 Bill Nottingham 2000-11-13 15:46:20 EST

*** This bug has been marked as a duplicate of 20696 ***

Note You need to log in before you can comment on or make changes to this bug.