Bug 193674 - Lua does no require pkgconfig
Lua does no require pkgconfig
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lua (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Michael J Knox
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-BuildReq
  Show dependency treegraph
 
Reported: 2006-05-31 11:55 EDT by Matthias Saou
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-31 16:02:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthias Saou 2006-05-31 11:55:12 EDT
The current lua package now uses the pkgconfig .pc file instead of the no longer
included lua-config script. A requirement on pkgconfig is now needed, but it
might then be a good time to split lua and lua-devel into two since it would
currently mean adding a development type of requirement to a main package.

I've made this block the FE-BuildReq bug since I discovered this problem when
looking at the lighttpd build logs, which indicated a failure because of
pkgconfig not being installed when trying to enable lua support.
Comment 1 Michael J Knox 2006-05-31 15:33:56 EDT
Could you provide some more details? maybe a build log etc?

If you go here:

http://linux.dell.com/files/fedora/FixBuildRequires/mock-results-extras/i386/lua-5.1-3.fc6.src.rpm/result/

lua builds without the need for pkg-config. At no time during the build is
pkg-config called. 
Comment 2 Michael J Knox 2006-05-31 15:43:05 EDT
Cancel that. I just clicked to what you meant. 

Will push a rebuild tonight. 
Comment 3 Michael J Knox 2006-05-31 16:02:16 EDT
Fixed in lua-5.1-4. 
Comment 4 Matthias Saou 2006-05-31 20:12:09 EDT
Thanks.
But what about the idea of splitting off a real -devel sub-package? When there
were no dependencies and only a static library, it didn't make much sense, but
now I really think it does.
Comment 5 Michael J Knox 2006-06-05 22:34:03 EDT
OK, I have split it out and it should be in the repos in the next push. Thanks!

Note You need to log in before you can comment on or make changes to this bug.