Bug 193694 - MAKEDEV-3.15.2-3 contains symbolic link /dev/MAKEDEV conflicting with udev /sbin/start_udev
MAKEDEV-3.15.2-3 contains symbolic link /dev/MAKEDEV conflicting with udev /s...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: MAKEDEV (Show other bugs)
4.0
All Linux
medium Severity low
: ---
: ---
Assigned To: Chris Lumens
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-05-31 13:23 EDT by wingc
Modified: 2008-06-26 21:56 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHEL5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-26 21:56:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wingc 2006-05-31 13:23:22 EDT
Description of problem:

The latest MAKEDEV package now includes /dev/MAKEDEV in its file list, as a
symbolic link to '../sbin/MAKEDEV'.  However, the /sbin/start_udev script which
is part of the udev package, recreates this symbolic link at boot time as a link
to '/sbin/MAKEDEV' (without the leading '..').  As a result, an rpm verify on
the MAKEDEV package shows this this link has been altered.

Version-Release number of selected component (if applicable):

MAKEDEV-3.15.2-3

How reproducible:

always

Steps to Reproduce:
1. Upgrade RHEL4 to latest MAKEDEV package (3.15.2-3)
2. Reboot your computer
3. Observe that at boot time, /sbin/start_udev recreates /dev/MAKEDEV link with
different link target than contents of MAKEDEV RPM.

Actual results:

'rpm -V MAKEDEV' will now report a verify error:

    % rpm -V MAKEDEV
    ....L...C   /dev/MAKEDEV

Expected results:

'rpm -V' should not show any changes to the MAKEDEV package on a generic RHEL4
system (one which has not been altered by the system administrator).

Additional info:


It would seem that the solution to this problem would be one of the following:

    1. Update the MAKEDEV package and correct the symbolic link so that it contains:
        /dev/MAKEDEV -> /sbin/MAKEDEV
    instead of:
        /dev/MAKEDEV -> ../sbin/MAKEDEV

    2. Update the udev package instead, and modify /sbin/start_udev so that when
it recreates the link at boot time, it creates the link pointing to
'../sbin/MAKEDEV' to match the contents of the MAKEDEV RPM package.

    3. Remove the /dev/MAKEDEV from the MAKEDEV package.
Comment 1 Nalin Dahyabhai 2006-05-31 16:54:56 EDT
Harald, any opinion here?  I'm fine with either 1 or 2, but I don't think 3 is
an option....
Comment 2 Harald Hoyer 2006-06-01 07:11:00 EDT
Hmm, but /dev/MAKEDEV in MAKEDEV does not make sense, since /dev is a mounted
tmpfs (by initrd).
Comment 3 Nalin Dahyabhai 2006-06-05 11:16:45 EDT
It used to make sense, and is still required in FHS 2.3 "if it is possible that
devices will need to be manually created", which is a little vague if you ask
me.  Otherwise I'd be in favor of removing it as well.
Comment 4 Chris Lumens 2008-06-26 21:56:14 EDT
The MAKEDEV package in RHEL5 no longer contains the /dev/MAKEDEV file, though it
is created as a symlink by something else.  The symlink points to /sbin/MAKEDEV
so this should be fine.

Note You need to log in before you can comment on or make changes to this bug.