Bug 193696 - Not using all available system memory - swapping too aggressive - high load average (iowait)
Not using all available system memory - swapping too aggressive - high load a...
Status: CLOSED DUPLICATE of bug 188141
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks: 181409
  Show dependency treegraph
 
Reported: 2006-05-31 13:33 EDT by David Herselman
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 13:36:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MRTG graph of available system memory show system not using everything before starting to aggressively swap (229.10 KB, application/pdf)
2006-05-31 13:33 EDT, David Herselman
no flags Details

  None (edit)
Description David Herselman 2006-05-31 13:33:26 EDT
Description of problem:
  System swaps too aggressively and only utilises +-30% of available system
  memory (reading discussion threads indicates that this only shows up when
  the system has more than 1GB of RAM).

Version-Release number of selected component (if applicable):
  RHEL4.3
  kernel-2.6.9-34.0.1.EL

How reproducible:
  Very

Steps to Reproduce:
1. AMD Athlon 64 3000+ Processor
2. nVidia nForce4 chipset (ASUS A8N5X Motherboard)
3. 1GB of RAM
  
Actual results:
  put load on the server and available system memory is +-750KB. Swap
  utilisation increases and processes increase slowing the system due to
  high iowait (aggressive memory swapping)

Expected results:
  Should only start swapping once system memory starts getting low, no?

Additional info:
  System was previously running RHEL3.7 without problems, MRTG display of
  available system memory shows the problem quite clearly (attached).

  RedHat do have a document called 'Understanding Virtual Memory In Red Hat
  Enterprise Linux 4' but I simply don't understand what I should be changing:
    http://people.redhat.com/nhorman/papers/rhel4_vm.pdf
Comment 1 David Herselman 2006-05-31 13:33:26 EDT
Created attachment 130298 [details]
MRTG graph of available system memory show system not using everything before starting to aggressively swap
Comment 2 Jason Baron 2006-05-31 13:36:58 EDT
hmmm...this looks a lot like bz #188141. Can you please try the U4 beat kernel
and let me know if this fixes it for you. The kernel is 2.6.9-37.
http://people.redhat.com/~jbaron/rhel4/
Comment 3 David Herselman 2006-05-31 13:40:17 EDT
Found additional information from other people experiencing the same issue
in CentOS 4:
  Bug ID:  0001174
  Summary: Extremely high load average and 100% CPU utilization 
  URL:     http://bugs.centos.org/view.php?id=1174
Comment 4 Jason Baron 2006-05-31 13:54:42 EDT
Yes, i'm aware of this. I'm pretty sure the U4 beta kernel mention =ed in
comment #2 will resolve this issue. Also, just to be clear no VM tuning should
be needed. 
Comment 5 David Herselman 2006-05-31 16:24:06 EDT
The kernel-2.6.9-37.EL perfectly resolves the problem we were experiencing.

Many thanks for your prompt assistance!
Comment 6 Jason Baron 2006-06-01 13:36:40 EDT
glad to hear that :)

*** This bug has been marked as a duplicate of 188141 ***

Note You need to log in before you can comment on or make changes to this bug.