Bug 1937286 - The ISO from 20210308 does not boot at all on Fedora 34 KVM.
Summary: The ISO from 20210308 does not boot at all on Fedora 34 KVM.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: IoT
Version: 34
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Peter Robinson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-10 09:47 UTC by Lukas Ruzicka
Modified: 2021-03-10 12:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-10 12:20:41 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)
Messages and maintenance mode (33.61 KB, image/png)
2021-03-10 09:47 UTC, Lukas Ruzicka
no flags Details

Description Lukas Ruzicka 2021-03-10 09:47:17 UTC
Created attachment 1762236 [details]
Messages and maintenance mode

Description of problem:

Downloaded the above mentioned ISO to try several test case in scope of Fedora IoT test day, but I cannot boot it in the virtual machine. I have not tried to boot this on a bare-metal yet. 

The validation checks pass without any problems, so the error will not be caused by improperly downloaded media. 

The boot process hangs for a while on "Reached Basic target", then there are lots of dracut-initqueue messages and after a while the whole process ends up in the maintenance mode.

Version-Release number of selected component (if applicable):

Fedora-IoT-IoT-dvd-x86_64-34-20210308.0.iso

How reproducible:

Always

Steps to Reproduce:
1. Try to boot the ISO in the libvirt virtual machine.

Actual results:

Does not boot.

Expected results:

Should boot and start Anaconda for installation.

Additional info:

See attachment with messages and the final status.

Comment 1 Peter Robinson 2021-03-10 09:57:24 UTC
> Fedora-IoT-IoT-dvd-x86_64-34-20210308.0.iso

Should be using the following iso:
https://dl.fedoraproject.org/pub/alt/iot/branched/IoT/x86_64/iso/Fedora-IoT-IoT-ostree-x86_64-34-20210308.0.iso

Does that one have the same issue?

Comment 2 Lukas Ruzicka 2021-03-10 10:20:07 UTC
I will check and let you know.

Comment 3 Lukas Ruzicka 2021-03-10 10:52:35 UTC
I can confirm that the ISO provided in comment #1 does boot normally. Thanks.

Comment 4 Peter Robinson 2021-03-10 11:56:08 UTC
(In reply to Lukas Ruzicka from comment #3)
> I can confirm that the ISO provided in comment #1 does boot normally. Thanks.

Why have you set a needinfo and why to that person?

Comment 5 Lukas Ruzicka 2021-03-10 12:17:45 UTC
(In reply to Peter Robinson from comment #4)
> (In reply to Lukas Ruzicka from comment #3)
> > I can confirm that the ISO provided in comment #1 does boot normally. Thanks.
> 
> Why have you set a needinfo and why to that person?

I wanted to reply to you and wanted to make sure that you get it ASAP, so I named you in the original message, but it seems this set a needinfo to that person, although I unchecked the needinfo tick - so no idea why it was set.

By the way, I have also tried to run this test case https://fedoraproject.org/wiki/QA:Testcase_Podman and it does not build the container with httpd and complains about "being unable to download packages". Is that a bug, too, or is the test cases outdated?

Thanks for clarification.

Comment 6 Peter Robinson 2021-03-10 12:20:41 UTC
Please don't set needinfo for times when you don't actually need info. Furthermore make sure you're setting it to the right person!


Note You need to log in before you can comment on or make changes to this bug.