Bug 193778 - SDL fails to build in mock
SDL fails to build in mock
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks: BuildReqBlocker
  Show dependency treegraph
 
Reported: 2006-06-01 11:32 EDT by Paul Howarth
Modified: 2013-01-09 22:53 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 05:06:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Build log with minimal build environment (34.46 KB, text/plain)
2006-06-01 11:32 EDT, Paul Howarth
no flags Details

  None (edit)
Description Paul Howarth 2006-06-01 11:32:30 EDT
This package fails to build in mock.  build.log is attached.

The reason for the failure is that, when compiling ./src/events/SDL_events.c,
this happens:
In file included from ./src/events/../video/SDL_sysvideo.h:37,
                 from ./src/events/SDL_sysevents.h:24,
                 from ./src/events/SDL_events.c:28:
./include/SDL_opengl.h:45:58: error: GL/glu.h: No such file or directory

Adding a buildreq of mesa-libGLU-devel supplies this file and allows the build
to complete.

Since the header file SDL_opengl.h is shipped in the SDL-devel package, I
believe that mesa-libGLU-devel should also be added as a dependency of the
SDL-devel package,
Comment 1 Paul Howarth 2006-06-01 11:32:30 EDT
Created attachment 130351 [details]
Build log with minimal build environment
Comment 2 Thomas Woerner 2006-06-06 05:06:09 EDT
Fixed in rawhide in rpm SDL-1.2.10-2 or newer.
Comment 3 Wart 2006-06-14 18:09:48 EDT
(In reply to comment #0)

> Since the header file SDL_opengl.h is shipped in the SDL-devel package, I
> believe that mesa-libGLU-devel should also be added as a dependency of the
> SDL-devel package,

Shouldn't this require the more generic libGL-devel and libGLU-devel (both of
which are provided by mesa-libGL(U)-devel) instead of requiring a specific GL
implementation?
Comment 4 Paul Howarth 2006-06-16 10:32:02 EDT
(In reply to comment #3)
> (In reply to comment #0)
> 
> > Since the header file SDL_opengl.h is shipped in the SDL-devel package, I
> > believe that mesa-libGLU-devel should also be added as a dependency of the
> > SDL-devel package,
> 
> Shouldn't this require the more generic libGL-devel and libGLU-devel (both of
> which are provided by mesa-libGL(U)-devel) instead of requiring a specific GL
> implementation?

Sounds reasonable to me, as long as all GL(U) implementations can be relied upon
to provide GL/glu.h.

Note You need to log in before you can comment on or make changes to this bug.