RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1937938 - [Rebase] Rebase to latest upstream
Summary: [Rebase] Rebase to latest upstream
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: rhel-system-roles
Version: 8.5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 8.5
Assignee: Rich Megginson
QA Contact: David Jež
Eliane Ramos Pereira
URL:
Whiteboard:
Depends On:
Blocks: 1695634 1757869 1848683 1927905 1938014 1938016 1938020 1938023 1939702 1939711 1943679
TreeView+ depends on / blocked
 
Reported: 2021-03-11 18:40 UTC by Rich Megginson
Modified: 2021-11-09 20:30 UTC (History)
6 users (show)

Fixed In Version: rhel-system-roles-1.1.0-1.el8
Doc Type: Rebase: Bug Fixes and Enhancements
Doc Text:
.`rhel-system-roles` package rebased to version 1.2.2-3 The `rhel-system-roles` package has been upgraded to version 1.2.2-3. Notable changes include: * Support for RHEL9 is available to the RHEL System Roles and they can now manage RHEL 9 hosts. * Support for Ansible 2.7 is deprecated.
Clone Of:
Environment:
Last Closed: 2021-11-09 17:44:47 UTC
Type: Bug
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2021:4159 0 None None None 2021-11-09 17:45:14 UTC

Description Rich Megginson 2021-03-11 18:40:20 UTC
Description of problem:

Rebase all system roles to latest upstream.  Note that we will probably do this several times before the final 8.5 target ITM.

Get rid of patches we are carrying if possible.

This rebase will add features and fix bugs - we must get QE and docs approval.  If the features/bugs are significant, we will require separate bzs linked to this bz.  In some cases there are existing bzs that will be fixed by the rebase - those bzs will also be linked to this bz.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 4 Jakub Jelen 2021-04-08 11:21:52 UTC
Please, pull also the latest changes from the ssh role: https://github.com/linux-system-roles/ssh/commit/59b9fd7b25607d8bd33bdb082748955f2652846a

It has a couple of documentation issues we talked about earlier fixed and support for RHEL9.

Comment 17 errata-xmlrpc 2021-11-09 17:44:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (rhel-system-roles bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:4159


Note You need to log in before you can comment on or make changes to this bug.