Bug 193795 - clearsilver fails to build on rawhide
Summary: clearsilver fails to build on rawhide
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: clearsilver   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Joost Soeterbroek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FE-BuildReq
TreeView+ depends on / blocked
 
Reported: 2006-06-01 17:53 UTC by Paul Howarth
Modified: 2013-01-10 03:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-01 19:22:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix ruby install directory locations (1.20 KB, patch)
2006-06-01 17:53 UTC, Paul Howarth
no flags Details | Diff

Description Paul Howarth 2006-06-01 17:53:00 UTC
This package is mongst the ones listed in the "fails to build in mock" report
posted to fedora-extras-list and fedora-devel-list daily. The problem isn't
actually due to missing buildrequires, it's due to the ruby package in
development putting things in different places, which don't line up with the
%files list.

I have attached a patch that will fix this for rawhide whilst remaining
spec-compatible with FC5 ruby (and possibly older versions too).

The patch changes the hardcoded locations to use the ruby sitelib and sitearch
locations as described in the Packaging/Ruby page on the wiki.

Comment 1 Paul Howarth 2006-06-01 17:53:00 UTC
Created attachment 130355 [details]
Patch to fix ruby install directory locations

Comment 2 Joost Soeterbroek 2006-06-01 19:22:49 UTC
Fixed.
Thanks Paul.


Note You need to log in before you can comment on or make changes to this bug.