Bug 1937986 - [4.6]wrong community catalog image reference
Summary: [4.6]wrong community catalog image reference
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: OLM
Version: 4.6
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 4.6.z
Assignee: Joe Lanford
QA Contact: Jian Zhang
URL:
Whiteboard:
Depends On: 1937998
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-11 20:32 UTC by Ben Parees
Modified: 2021-03-30 17:03 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1937998 (view as bug list)
Environment:
Last Closed: 2021-03-30 17:03:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github operator-framework operator-marketplace pull 384 0 None open Bug 1937986: wrong community catalog image reference 2021-03-15 16:43:53 UTC
Red Hat Product Errata RHBA-2021:0952 0 None None None 2021-03-30 17:03:24 UTC

Description Ben Parees 2021-03-11 20:32:35 UTC
Description of problem:
OCP 4.6 is setting up the community catalog to pull this image:
registry.redhat.io/redhat/community-operator-index:latest

as defined here:
https://github.com/operator-framework/operator-marketplace/blob/release-4.6/defaults/03_community_operators.yaml#L8


but it should be referencing
registry.redhat.io/redhat/community-operator-index:v4.6


Version-Release number of selected component (if applicable):
4.6

How reproducible:
always

Steps to Reproduce:
1. install cluster
2. check image reference in community catalog
3. see that it refs a :latest tag

Actual results:
refs :latest tag

Expected results:
refs :v4.6 tag


Additional info:

v4.7 is doing the right thing(refs v4.7).  v4.8 is ref'ing v4.7 but that's also "ok" because there is no v4.8 community catalog currently.

Comment 1 Ben Parees 2021-03-11 21:24:36 UTC
fyti v4.6 and latest tags appear to point to the same SHA currently, so it's not an *immediate* concern.  I assume that's deliberate.

But if for some reason someone updates latest to 4.7 or later, it would be very bad for our 4.6 clusters.

also if for some reason someone deleted the latest tag (since it's "not used" any more) that would also be bad.

So we should still fix this asap.

The good news is, since latest and v4.6 point the same place, there should be no risk to 4.6 clusters that the switch causes their catalog of operators to change.

Comment 2 Joe Lanford 2021-03-15 16:38:18 UTC
Bumping this down to medium prio/medium severity because the registry pipeline team reports that `latest` is tracking `v4.6` for the community-operators image and will not be moved to track v4.7.

Comment 4 Jian Zhang 2021-03-22 02:20:42 UTC
Cluster version is 4.6.0-0.nightly-2021-03-21-131139
1, Check the label of the index image of the community operator.
[jzhang@dhcp-140-36 ~]$ oc project openshift-marketplace
Now using project "openshift-marketplace" on server "https://api.ci-ln-rgs5dwt-f76d1.origin-ci-int-gce.dev.openshift.com:6443".
[jzhang@dhcp-140-36 ~]$ oc get catalogsource
NAME                  DISPLAY               TYPE   PUBLISHER   AGE
certified-operators   Certified Operators   grpc   Red Hat     49m
community-operators   Community Operators   grpc   Red Hat     49m
redhat-marketplace    Red Hat Marketplace   grpc   Red Hat     49m
redhat-operators      Red Hat Operators     grpc   Red Hat     49m
[jzhang@dhcp-140-36 ~]$ oc get catalogsource community-operators -o=jsonpath={.spec.image}
registry.redhat.io/redhat/community-operator-index:v4.6

2, Install an operator from this community catalog source, for example, etcd-operator
[jzhang@dhcp-140-36 ~]$ cat sub-etcd.yaml 
apiVersion: operators.coreos.com/v1alpha1
kind: Subscription
metadata:
  name: sub-etcd2
  namespace: default
spec:
  sourceNamespace: openshift-marketplace
  channel: singlenamespace-alpha
  installPlanApproval: Automatic
  name: etcd
  source: community-operators
  startingCSV: etcdoperator.v0.9.4
[jzhang@dhcp-140-36 ~]$ oc create -f sub-etcd.yaml 
subscription.operators.coreos.com/sub-etcd2 created

[jzhang@dhcp-140-36 ~]$ oc get sub -n default
NAME        PACKAGE   SOURCE                CHANNEL
sub-etcd2   etcd      community-operators   singlenamespace-alpha
[jzhang@dhcp-140-36 ~]$ oc get ip -n default
NAME            CSV                   APPROVAL    APPROVED
install-l52p9   etcdoperator.v0.9.4   Automatic   true
[jzhang@dhcp-140-36 ~]$ oc get csv -n default
NAME                  DISPLAY   VERSION   REPLACES              PHASE
etcdoperator.v0.9.4   etcd      0.9.4     etcdoperator.v0.9.2   Succeeded
[jzhang@dhcp-140-36 ~]$ oc get pods -n default
NAME                            READY   STATUS    RESTARTS   AGE
etcd-operator-bfcbcb5dc-jh5jd   3/3     Running   0          53s

LGTM, verify it.

Comment 7 errata-xmlrpc 2021-03-30 17:03:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.6.23 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:0952


Note You need to log in before you can comment on or make changes to this bug.