Bug 1937996 - ceph-ansible fails on RHOS 16.1.3 with msg: 'dict object' has no attribute 'mons' when using Manila with Ganesha and external Ceph
Summary: ceph-ansible fails on RHOS 16.1.3 with msg: 'dict object' has no attribute 'm...
Keywords:
Status: CLOSED DUPLICATE of bug 1937997
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 4.0
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
: 4.2z2
Assignee: Guillaume Abrioux
QA Contact: Ameena Suhani S H
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-11 21:26 UTC by Ladislav Jozsa
Modified: 2021-03-22 13:26 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-22 13:26:18 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ladislav Jozsa 2021-03-11 21:26:50 UTC
Description of problem:
Fresh deploy of RHOS 16.1.3 failed with

        "TASK [ceph-facts : get ceph current status] ************************************",
        "Thursday 11 March 2021  19:31:31 +0000 (0:00:00.348)       0:00:28.255 ******** ",
        "fatal: [ctrl-storage-c-01]: FAILED! => {\"msg\": \"'dict object' has no attribute 'mons'\"}",

Our environment is configured with Manila and NFS Ganesha and we use external Ceph. 

Version-Release number of selected component (if applicable):
ceph-ansible-4.0.41-1.el8cp.noarch

External Ceph version:
[storage-004.infra.prod.upshift.eng.rdu2.redhat.com] [09:23:32 PM]
[root@storage-004 ~]# ceph --version
ceph version 14.2.11-95.el7cp (1d6087ae858e7c8e72fe7390c3522c7e0d951240) nautilus (stable)

How reproducible:
100%

Steps to Reproduce:
1. Setup RHOS 16.1.3 with Manila, NFS Ganesha and external Ceph cluster
2. Attempt to run deploy
3.

Actual results:
Deploy fails on Ceph ansible with above described error.

Expected results:
Deploy passes.

Additional info:
Reproducible in PSI staging env.

Comment 1 Guillaume Abrioux 2021-03-22 13:26:18 UTC

*** This bug has been marked as a duplicate of bug 1937997 ***


Note You need to log in before you can comment on or make changes to this bug.