Bug 19381 - X11 forwarding is broken in 2.2.0
X11 forwarding is broken in 2.2.0
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: openssh (Show other bugs)
7.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-19 10:59 EDT by Gerald Teschl
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-23 08:39:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerald Teschl 2000-10-19 10:59:15 EDT
Summary says it all. VERY anoying!
Comment 1 Leigh L. Klotz, Jr. 2000-10-19 21:09:47 EDT
Is it broken or is it just off by default (contrary to what the man pages says).
For the client, see /etc/ssh/ssh_config and note that "ForwardX11 yes" is 
commented out. For the server, note that /etc/ssh/sshd_config is similar.

Users can turn it on for the ssh client themselves in their ~/.ssh/config file, 
but the the sshd server it must be set by root in /etc/sshd/sshd_config


Comment 2 Nalin Dahyabhai 2000-10-20 16:34:06 EDT
I'm not able to reproduce this.  Are the machines on the client and server ends
of the connection both running the openssh-2.2.0 package, or is the server
running a different version?
Comment 3 Gerald Teschl 2000-10-23 07:37:07 EDT
Server/client are both RH7.0+updates.
Just found some time to investigate the problem further:

X11 forwarding is only broken if "UseLogin" is set to "yes"! 

------------------------------------------
[gerald@dopefish gerald]$ ssh localhost
Last login: Mon Oct 23 13:20:10 from localhost.localdomain
You have mail.
Mon Oct 23 13:26:22 CEST 2000
[gerald@dopefish gerald]$ xterm
channel 0: istate 4 != open
channel 0: ostate 64 != open
X connection to dopefish.esi.ac.at:10.0 broken (explicit kill or server shutdown

Comment 4 Gerald Teschl 2001-03-23 08:39:03 EST
Works now.

Note You need to log in before you can comment on or make changes to this bug.