Bug 193818 - spamd should start before sendmail
spamd should start before sendmail
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-01 16:27 EDT by Alexandre Oliva
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-14 13:49:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexandre Oliva 2006-06-01 16:27:49 EDT
Description of problem:
Users that rely on spamc/spamd for mail delivery might face silent mail delivery
failure if spamd is not running when sendmail attempts to deliver them e-mail. 
Starting spamd before sendmail would reduce the probability of such a problem.

Version-Release number of selected component (if applicable):
sendmail-8.13.6-1
spamassassin-3.1.2-1.fc6

How reproducible:
Every time

Steps to Reproduce:
1.Boot up

Actual results:
spamd starts after sendmail

Expected results:
It should start before

Additional info:
both are S80, which causes sendmail to start first since it sorts alphabetically
before spamd.
Comment 1 Paul Howarth 2006-06-02 03:35:09 EDT
(In reply to comment #0)
> Additional info:
> both are S80, which causes sendmail to start first since it sorts alphabetically
> before spamd.

It should also start before spamass-milter, which in Extras is S79 to ensure
that *it* starts before sendmail.
Comment 2 Warren Togami 2006-06-02 10:19:05 EDT
So S78 then?
Comment 3 Paul Howarth 2006-06-02 10:34:37 EDT
(In reply to comment #2)
> So S78 then?

WORKSFORME.

Comment 4 Warren Togami 2006-06-07 11:34:50 EDT
Going into FC6 for now.  Will bring this back into FC5 later.  Does chkconfig
properly handle removing the previous S80 files when this number is changed?
Comment 5 Paul Howarth 2006-06-07 12:30:01 EDT
(In reply to comment #4)
> Going into FC6 for now.  Will bring this back into FC5 later.  Does chkconfig
> properly handle removing the previous S80 files when this number is changed?

No, you would need some trickery like this to fix the starting sequence:

/sbin/chkconfig --add spamassassin
LEVELS=$(/sbin/chkconfig --list spamassassin | sed -e 's/[0-6]:off//g;s/[^0-6]//g')
/sbin/chkconfig --del spamassassin
/sbin/chkconfig --add spamassassin
[ -n "$LEVELS" ] && /sbin/chkconfig --levels $LEVELS spamassassin on

The first --add makes sure that chkconfig knows about spamassassin for a
first-time install, and has no effect on upgrades.

The subsequent stuff records the current runlevels, removes the existing links,
adds in new ones, and restores the runlevels to the original settings.

A facility to do something like this would be nice to have within chkconfig
itself of course.
Comment 6 Warren Togami 2006-06-07 15:13:09 EDT
Argh... this is quite a mess.
Comment 7 Paul Howarth 2006-11-08 05:16:49 EST
Since this is fixed in FC6, the bug can be closed, can't it?

Note You need to log in before you can comment on or make changes to this bug.