Bug 19382 - rpm --root xxx -i fails silently if user isn't root
Summary: rpm --root xxx -i fails silently if user isn't root
Status: CLOSED DUPLICATE of bug 49899
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 11510 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-19 15:09 UTC by Fox, David
Modified: 2007-04-18 16:29 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-29 18:21:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Fox, David 2000-10-19 15:09:13 UTC
Because the chroot call can only work for root, when I tried to install a
package into a temporary directory as a non-priviledged user it failed to
chroot and attempted to install
into /.  RPM should probably detect this case and signal an error, or at
least check the
result code from chroot.

It is unfortunate that regular users can't do this, but I suppose that is a
complaint for whoever
decreed that chroot shall only work for root.

Comment 1 Jeff Johnson 2001-07-29 18:21:45 UTC
*** Bug 11510 has been marked as a duplicate of this bug. ***

Comment 2 Jeff Johnson 2001-08-30 18:22:27 UTC
Collecting rpm needs root problems at #49899.

*** This bug has been marked as a duplicate of 49899 ***


Note You need to log in before you can comment on or make changes to this bug.