Bug 1938310 - Bug in bluez 5.56 accidentally removes remote SEPs from the cache and disconnects headphones
Summary: Bug in bluez 5.56 accidentally removes remote SEPs from the cache and disconn...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: bluez
Version: 33
Hardware: x86_64
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Don Zickus
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-12 18:32 UTC by Richard Monk
Modified: 2021-03-22 02:07 UTC (History)
5 users (show)

Fixed In Version: bluez-5.56-4.fc34
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-03-22 02:07:22 UTC
Type: Bug


Attachments (Terms of Use)

Description Richard Monk 2021-03-12 18:32:56 UTC
Description of problem:

When using A2DP headphones, sometimes they will disconnect and reconnect after 10-20 minutes into HSP mode, and A2DP is unavailable.  After a bug report, this was discovered to be caused by accidentally removing remote SEPs.

Bug: https://github.com/bluez/bluez/issues/102
Patch to fix: https://github.com/tedd-an/bluez/commit/fac790455a8a2d1fd7973db1fed2f297d67f5d9f

Version-Release number of selected component (if applicable):
bluez-5.56-1

Steps to Reproduce:
1. Connect bluetooth headphones to your system
2. Play audio for some time

Actual results:
Audio will suddenly cut out with no warning, and the headphones will disconnect or reconnect in HSP mode. 

Expected results:
Audio keeps playing

Additional info:
Upstream has a patch to fix this, I patched bluez-5.56-1 on Fedora 33 x86_64 and the issue has not returned, so I think this is a good fix.

Comment 1 Fedora Update System 2021-03-14 19:37:04 UTC
FEDORA-2021-431d84c63e has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2021-431d84c63e

Comment 2 Fedora Update System 2021-03-16 14:42:10 UTC
FEDORA-2021-431d84c63e has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-431d84c63e`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2021-431d84c63e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 3 Fedora Update System 2021-03-22 02:07:22 UTC
FEDORA-2021-431d84c63e has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.