Bug 193880 - rssowl fails to start
rssowl fails to start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rssowl (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tom Tromey
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE6Target
  Show dependency treegraph
 
Reported: 2006-06-02 11:55 EDT by Anthony Green
Modified: 2014-08-11 01:46 EDT (History)
6 users (show)

See Also:
Fixed In Version: rssowl-1.2.2-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-01 19:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 27271 None None None Never

  None (edit)
Description Anthony Green 2006-06-02 11:55:19 EDT
Description of problem:
A recent change in either gcc or eclipse broke rssowl.  We get the following
stack trace now...

Exception in thread "main" org.eclipse.swt.SWTException: i/o error
(java.util.zip.ZipException: Deflated stream ends early.)
   at org.eclipse.swt.SWT.error(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at org.eclipse.swt.SWT.error(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.internal.image.GIFFileFormat.readID(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.internal.image.GIFFileFormat.getExtensions(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.internal.image.GIFFileFormat.loadFromByteStream(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.internal.image.FileFormat.loadFromStream(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.internal.image.FileFormat.load(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.graphics.ImageLoader.load(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.graphics.ImageDataLoader.load(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.graphics.ImageData.<init>(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at
org.eclipse.swt.graphics.Image.<init>(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   at net.sourceforge.rssowl.util.shop.PaintShop.loadImage(rssowl.jar.so)
   at net.sourceforge.rssowl.util.shop.PaintShop.loadImage(rssowl.jar.so)
   at net.sourceforge.rssowl.util.shop.PaintShop.initIcons(rssowl.jar.so)
   at net.sourceforge.rssowl.controller.GUI.startUp(rssowl.jar.so)
   at net.sourceforge.rssowl.controller.GUI.<init>(rssowl.jar.so)
   at net.sourceforge.rssowl.controller.RSSOwlLoader.<init>(rssowl.jar.so)
   at net.sourceforge.rssowl.controller.RSSOwlLoader.main(rssowl.jar.so)
Caused by: java.util.zip.ZipException: Deflated stream ends early.
   at java.util.zip.InflaterInputStream.fill(libgcj.so.7)
   at java.util.zip.InflaterInputStream.read(libgcj.so.7)
   at java.util.zip.InflaterInputStream.read(libgcj.so.7)
   at java.io.FilterInputStream.read(libgcj.so.7)
   at java.util.jar.JarFile$EntryInputStream.read(libgcj.so.7)
   at
org.eclipse.swt.internal.image.LEDataInputStream.read(org.eclipse.swt.gtk.linux.x86_3.1.1.jar.so)
   ...16 more

Version-Release number of selected component (if applicable):

libgcj-4.1.1-1.fc5
libswt3-gtk2-3.1.2-1jpp_15fc
rssowl-1.2.1-2.fc5

How reproducible:
Always

Steps to Reproduce:
1. start rssowl
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Anthony Green 2006-06-02 11:58:56 EDT
mjw suggests that it's related to GCC bug 27271.  I've added that as an external
bugzilla reference for now.
Comment 2 Ben Konrath 2006-06-02 12:13:23 EDT
I just tested rssowl with the recently updated GCJ (gcc-java-4.1.1-1.fc5) and
the previous version of Eclipse (eclipse-rcp-3.1.2-1jpp_13fc). I get the same
error so I think it's a GCJ problem.
Comment 3 Tom Tromey 2006-07-11 18:01:41 EDT
I'm looking at this.
Comment 4 Tom Tromey 2006-07-12 12:38:17 EDT
I checked in a fix to the gcc svn 4.1 branch.
It is revision 115377.

Jakub, I CCd you on this since it would be nice to have this patch
put in an FC5 update.
Comment 5 Anthony Green 2006-08-26 23:34:58 EDT
Jakub: will libgcj ever be updated in FC5?  If not, I should look into removing
rssowl from FC5 extras.
Comment 6 Anthony Green 2006-09-01 19:59:34 EDT
tromey suggested the obvious work around (use an uncompressed jar file!), and
RSSOwl in FC5 Extras is working again.

Note You need to log in before you can comment on or make changes to this bug.