Bug 1938923 - Router HAProxy config file template is slow to render due to repetitive regex compilations
Summary: Router HAProxy config file template is slow to render due to repetitive regex...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing
Version: 3.11.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 4.5.z
Assignee: Andrew McDermott
QA Contact: Arvind iyengar
URL:
Whiteboard:
Depends On: 1938922
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-15 08:30 UTC by OpenShift BugZilla Robot
Modified: 2021-04-28 14:24 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-04-28 14:23:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift router pull 271 0 None open [release-4.5] Bug 1938923: router/template: Cache compiled regular expressions 2021-03-16 17:08:11 UTC
Red Hat Product Errata RHBA-2021:1300 0 None None None 2021-04-28 14:24:00 UTC

Comment 2 Hongan Li 2021-04-06 05:46:57 UTC
verified with 4.5.0-0.nightly-2021-04-05-191932 and no regression, moving to verified.

router logs with more that 3k routes:
I0406 03:48:43.500628       1 router.go:425] template "msg"="writeConfig"  "duration"="482.545799ms"
I0406 03:48:48.524396       1 router.go:425] template "msg"="writeConfig"  "duration"="506.148406ms"
I0406 03:48:53.515454       1 router.go:425] template "msg"="writeConfig"  "duration"="497.081666ms"

Comment 5 errata-xmlrpc 2021-04-28 14:23:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.5.38 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1300


Note You need to log in before you can comment on or make changes to this bug.