Bug 193916 - mkisofs produces erroneous "Unknown file type (unallocated)" warning
mkisofs produces erroneous "Unknown file type (unallocated)" warning
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cdrtools (Show other bugs)
4.0
i386 Linux
medium Severity high
: rc
: ---
Assigned To: Harald Hoyer
: Reopened
Depends On:
Blocks: 176344 435953
  Show dependency treegraph
 
Reported: 2006-06-02 17:49 EDT by Xixi
Modified: 2010-10-22 01:03 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 174667
Environment:
Last Closed: 2009-05-18 16:29:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (454 bytes, patch)
2008-07-15 06:35 EDT, Harald Hoyer
no flags Details | Diff

  None (edit)
Description Xixi 2006-06-02 17:49:52 EDT
+++ This bug was initially created as a clone of Bug #174667 +++

From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; MSIE 6.0; Windows; U; AIIEEEE!; Win98;
Windows 98; en-US; Gecko masquerading as IE; should it matter?; rv:1.8b)
Gecko/20050217

Description of problem:
When running mkisfs sometimes you might get error such as:

    Unknown file type (unallocated) /some/path/.. - ignoring and continuing.

To reliably reproduce this bug you need to create a directory such that the ".."
directory entry preceeds the "." directory entry when opendir()/readdir() runs.
Quite frankly I don't know how you can go about achieving this. All I know is
that I have one such directory and mkisofs code depends on it discovering the
"." entry before the ".." entry (because when mkisofs encounters the ".." entry
it switches its lstatbuf with that which was saved from the "." entry - see
mkisofs/tree.c).

Version-Release number of selected component (if applicable):
mkisofs-2.01.1-9.0.FC4.1  cdrtools-2.01.1-9.0.FC4.1

How reproducible:
Always

Steps to Reproduce:
1.Create directory /some/path with ".." having directory slot before "." entry
2.mkisofs -o /dev/null /some/path
3.
  

Actual Results:  Unknown file type (unallocated) /some/path/.. - ignoring and
continuing.

Expected Results:  No output


Additional info:

-- Additional comment from redhat@zacglen.com.au on 2005-12-01 04:14 EST --
*** Bug 174665 has been marked as a duplicate of this bug. ***

-- Additional comment from redhat@zacglen.com.au on 2006-04-19 07:43 EST --
Perhaps somebody might explain why this ticket suddenly closed itself a few
minutes ago.  I certainly didn't.

Why wont the bug be fixed?


-- Additional comment from harald@redhat.com on 2006-04-19 12:43 EST --
I see the bug, but I wont fix this. Please report this bug to the author of
mkisofs. The fix would need some more changes, than I am willing to patch in
every version.
Comment 11 Harald Hoyer 2008-07-15 06:35:09 EDT
Created attachment 311798 [details]
proposed patch
Comment 18 Jörg Schilling 2009-02-10 11:04:17 EST
Your problem has been fixed in the original software some time
ago....

The patch from harald is not sufficient to make things right.

Please fetch recent original software from:

ftp://ftp.berlios.de/pub/cdrecord/alpha/
Comment 21 errata-xmlrpc 2009-05-18 16:29:38 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1007.html

Note You need to log in before you can comment on or make changes to this bug.