This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 193926 - Broken in text mode
Broken in text mode
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-keyboard (Show other bugs)
5
All Linux
low Severity high
: ---
: ---
Assigned To: Paul Nasrat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-02 19:30 EDT by Alan Cox
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 16:36:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Alan Cox 2006-06-02 19:30:49 EDT
If your locale is en_GB.UTF_8 (and maybe others, untested) then running
system-config-keyboard on a console when X cannot be started produces a mangled
display that looks like incorrect use of unicode versus graphics drawing
characters. This makes it damn near impossible for anyone but an expert to fix a
keyboard config problem on a server box.
Comment 1 Paul Nasrat 2006-06-26 15:33:07 EDT
LC_ALL=en_GB.UTF-8 system-config-keyboard --text on FC-5 looks fine to me, as
does rawhide.   

what does /etc/sysonfig/i18n say?  rpm -q kbd; rpm -V kbd


Comment 2 Alan Cox 2006-06-26 16:32:16 EDT
cy_GB.UTF-8

Alan
Comment 3 Alan Cox 2006-06-26 16:36:13 EDT
S.5....T    /lib/kbd/keymaps/i386/qwerty/uk.map.gz
missing     /lib/kbd/keymaps/i386/qwerty/us-acentos.map.gz
missing     /lib/kbd/keymaps/i386/qwerty/us.map.gz


Umm.... escaped i386 bits

Fixed and now works

Note You need to log in before you can comment on or make changes to this bug.