Bug 193937 - need acpi_skip_timer_override on 32bit 4u3
need acpi_skip_timer_override on 32bit 4u3
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brian Maly
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-02 22:10 EDT by Dan Carpenter
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 21:45:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (1.82 KB, text/plain)
2006-06-02 22:11 EDT, Dan Carpenter
no flags Details
dmesg for reference (19.33 KB, application/octet-stream)
2006-06-02 22:12 EDT, Dan Carpenter
no flags Details
kernel panic dmesg (4.70 KB, text/plain)
2006-06-05 15:24 EDT, Dan Carpenter
no flags Details
dmidecode output (14.62 KB, text/plain)
2006-06-07 18:49 EDT, Dan Carpenter
no flags Details
lspci output (1.82 KB, text/plain)
2006-06-07 21:26 EDT, Dan Carpenter
no flags Details
backport of RHEL4 x86_64 patch to resolve the issue (668 bytes, patch)
2006-10-04 12:53 EDT, Brian Maly
no flags Details | Diff

  None (edit)
Description Dan Carpenter 2006-06-02 22:10:35 EDT
Description of problem:  Occasionally the system won't find a time source on
boot and so it kernel panics before reaching the initrd.  rhel4u3 64bit software
works but the 32 bit software doesn't work.  It works if you specify
"acpi_skip_timer_override".  This is an nvidia based motherboard.


Version-Release number of selected component (if applicable):  2.6.9-34.ELsmp


How reproducible:  kernel panics 10% of the time.


Steps to Reproduce:
1.  Boot
2.
3.
  
Actual results:  It says it tries a couple time sources and can't get one so it
dies.  I'll set up a serial console on Monday and collect the full dmesg from a
failed boot.


Expected results:


Additional info:
Comment 1 Dan Carpenter 2006-06-02 22:11:55 EDT
Created attachment 130438 [details]
lspci
Comment 2 Dan Carpenter 2006-06-02 22:12:24 EDT
Created attachment 130439 [details]
dmesg for reference
Comment 3 Dan Carpenter 2006-06-05 15:24:33 EDT
Created attachment 130535 [details]
kernel panic dmesg
Comment 4 Brian Maly 2006-06-07 11:55:18 EDT
Some changes in this code went into U4 which may or may not resolve this issue.
Please verify the problem still exists in U4, and this issue can be queued for
the RHEL4 U5 release. If this issue does still exist in U4, please provide more
info on the exact system that exibits the problem... a "dmidecode" output might
be helpfull, but simply listing the exact make and model of the system would be
enough.

Comment 5 Dan Carpenter 2006-06-07 18:48:25 EDT
Ok, I'll test those when they become available.  There aren't any kernel
packages in the beta channel on rhn yet (and u4 itself hasn't been released
obviously).

I'm going to attach the DMI data.
Comment 6 Dan Carpenter 2006-06-07 18:49:36 EDT
Created attachment 130713 [details]
dmidecode output
Comment 7 Dan Carpenter 2006-06-07 21:25:32 EDT
The difference between x86_64 and i386 is that in x86_64 it does an lspci in
check_ioapic() in arch/x86_64/kernel/io_apic.c.  If there are any nvidia or via
pci bridges then it automatically turns on acpi_skip_timer_override.

I'm going to attach my lspci info as well.

Comment 8 Dan Carpenter 2006-06-07 21:26:13 EDT
Created attachment 130718 [details]
lspci output
Comment 10 Brian Maly 2006-10-04 12:53:28 EDT
Created attachment 137753 [details]
backport of RHEL4 x86_64 patch to resolve the issue

This issue had been previously addressed in RHEL4 for x86_64. This patch is a
backport of the x86_64 functionality to i386.
Comment 12 RHEL Product and Program Management 2006-10-11 11:16:22 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 13 Jay Turner 2006-10-17 11:32:15 EDT
QE ack for 4.5.
Comment 14 Ernie Petrides 2006-10-19 16:54:32 EDT
*** Bug 200412 has been marked as a duplicate of this bug. ***
Comment 16 Jason Baron 2007-01-10 13:54:51 EST
committed in stream U5 build 42.40. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 19 Red Hat Bugzilla 2007-05-07 21:45:56 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.