Note: This bug is displayed in read-only format because
the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Descriptionmxie@redhat.com
2021-03-16 13:17:19 UTC
Created attachment 1763619[details]
v2v-rhv-upload-qcow2-preallocated.log
Description of problem:
Can't set '-of qcow2 -oa preallocated' in v2v rhv-upload conversion on rhel8
Version-Release number of selected component (if applicable):
virt-v2v-1.42.0-9.module+el8.4.0+9561+069bb9c1.x86_64
libguestfs-1.44.0-2.module+el8.4.0+10146+75917d2f.x86_64
libvirt-libs-7.0.0-9.module+el8.4.0+10326+5e50a3b6.x86_64
qemu-kvm-5.2.0-12.module+el8.4.0+10354+98272afe.x86_64
nbdkit-1.24.0-1.module+el8.4.0+9341+96cf2672.x86_64
How reproducible:
100%
Steps to Reproduce:
1.Use v2v to convert guest from VMware to rhv via rhv-upload and set '-of qcow2 and -oa preallocated' in command line
# virt-v2v -ic vpx://root.198.169/data/10.73.199.217/?no_verify=1 -it vddk -io vddk-libdir=/home/vddk7.0 -io vddk-thumbprint=B5:52:1F:B4:21:09:45:24:51:32:56:F6:63:6A:93:5D:54:08:2D:78 -o rhv-upload -oc https://hp-dl360eg8-03.lab.eng.pek2.redhat.com/ovirt-engine/api -ip /home/passwd -op /home/rhvpasswd -os nfs_data -b ovirtmgmt -oo rhv-cluster=NFS esx7.0-win2019-static-ip -of qcow2 -oa preallocated
[ 0.5] Opening the source -i libvirt -ic vpx://root.198.169/data/10.73.199.217/?no_verify=1 esx7.0-win2019-static-ip -it vddk -io vddk-libdir=/home/vddk7.0 -io vddk-thumbprint=B5:52:1F:B4:21:09:45:24:51:32:56:F6:63:6A:93:5D:54:08:2D:78
[ 2.2] Creating an overlay to protect the source from being modified
[ 3.1] Opening the overlay
[ 7.5] Inspecting the overlay
[ 11.1] Checking for sufficient free disk space in the guest
[ 11.1] Estimating space required on target for each disk
[ 11.1] Converting Windows Server 2019 Standard to run on KVM
virt-v2v: warning: /usr/share/virt-tools/pnp_wait.exe is missing.
Firstboot scripts may conflict with PnP.
** (process:1142165): WARNING **: 16:18:30.395: Entity http://pcisig.com/pci/1B36/0100 referenced but not defined
virt-v2v: warning: there is no QXL driver for this version of Windows (10.0
x86_64). virt-v2v looks for this driver in
/usr/share/virtio-win/virtio-win.iso
The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[ 20.4] Mapping filesystem data to avoid copying unused and blank areas
[ 20.9] Closing the overlay
[ 21.2] Assigning disks to buses
[ 21.2] Checking if the guest needs BIOS or UEFI to boot
[ 21.2] Initializing the target -o rhv-upload -oa preallocated -oc https://hp-dl360eg8-03.lab.eng.pek2.redhat.com/ovirt-engine/api -op /home/rhvpasswd -os nfs_data
[ 22.5] Copying disk 1/1 to qemu URI json:{ "file.driver": "nbd", "file.path": "/tmp/v2vnbdkit.qi0eRl/nbdkit4.sock", "file.export": "/" } (qcow2)
nbdkit: python[1]: error: /tmp/v2v.F01RNk/rhv-upload-plugin.py: open: error: Traceback (most recent call last):
File "/tmp/v2v.F01RNk/rhv-upload-plugin.py", line 114, in open
disk = create_disk(connection)
File "/tmp/v2v.F01RNk/rhv-upload-plugin.py", line 494, in create_disk
name=params['output_storage'],
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/services.py", line 7813, in add
return self._internal_add(disk, headers, query, wait)
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 232, in _internal_add
return future.wait() if wait else future
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 55, in wait
return self._code(response)
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 229, in callback
self._check_fault(response)
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 132, in _check_fault
self._raise_error(response, body)
File "/usr/lib64/python3.6/site-packages/ovirtsdk4/service.py", line 118, in _raise_error
raise error
ovirtsdk4.Error: Fault reason is "Operation Failed". Fault detail is "[Cannot add Virtual Disk. Disk configuration (COW Preallocated backup-None) is incompatible with the storage domain type.]". HTTP response code is 409.
qemu-img: Could not open 'json:{ "file.driver": "nbd", "file.path": "/tmp/v2vnbdkit.qi0eRl/nbdkit4.sock", "file.export": "/" }': Requested export not available
virt-v2v: error: qemu-img command failed, see earlier errors
If reporting bugs, run virt-v2v with debugging enabled and include the
complete output:
virt-v2v -v -x [...]
Actual results:
As above description
Expected results:
Can set '-of qcow2 -oa preallocated' in v2v rhv-upload conversion on rhel8
Additional info:
1. Can set '-of qcow2 -oa sparse' in v2v rhv-upload conversion on rhel8
# virt-v2v -ic vpx://root.198.169/data/10.73.199.217/?no_verify=1 -it vddk -io vddk-libdir=/home/vddk7.0 -io vddk-thumbprint=B5:52:1F:B4:21:09:45:24:51:32:56:F6:63:6A:93:5D:54:08:2D:78 -o rhv-upload -oc https://hp-dl360eg8-03.lab.eng.pek2.redhat.com/ovirt-engine/api -ip /home/passwd -op /home/rhvpasswd -os nfs_data -b ovirtmgmt -oo rhv-cluster=NFS esx7.0-win2019-static-ip -of qcow2 -oa sparse
[ 0.5] Opening the source -i libvirt -ic vpx://root.198.169/data/10.73.199.217/?no_verify=1 esx7.0-win2019-static-ip -it vddk -io vddk-libdir=/home/vddk7.0 -io vddk-thumbprint=B5:52:1F:B4:21:09:45:24:51:32:56:F6:63:6A:93:5D:54:08:2D:78
[ 2.2] Creating an overlay to protect the source from being modified
[ 3.0] Opening the overlay
[ 7.5] Inspecting the overlay
[ 11.3] Checking for sufficient free disk space in the guest
[ 11.3] Estimating space required on target for each disk
[ 11.3] Converting Windows Server 2019 Standard to run on KVM
virt-v2v: warning: /usr/share/virt-tools/pnp_wait.exe is missing.
Firstboot scripts may conflict with PnP.
** (process:1154470): WARNING **: 21:09:43.120: Entity http://pcisig.com/pci/1B36/0100 referenced but not defined
virt-v2v: warning: there is no QXL driver for this version of Windows (10.0
x86_64). virt-v2v looks for this driver in
/usr/share/virtio-win/virtio-win.iso
The guest will be configured to use a basic VGA display driver.
virt-v2v: This guest has virtio drivers installed.
[ 21.1] Mapping filesystem data to avoid copying unused and blank areas
[ 21.7] Closing the overlay
[ 21.9] Assigning disks to buses
[ 21.9] Checking if the guest needs BIOS or UEFI to boot
[ 21.9] Initializing the target -o rhv-upload -oc https://hp-dl360eg8-03.lab.eng.pek2.redhat.com/ovirt-engine/api -op /home/rhvpasswd -os nfs_data
[ 23.2] Copying disk 1/1 to qemu URI json:{ "file.driver": "nbd", "file.path": "/tmp/v2vnbdkit.7CfsFP/nbdkit4.sock", "file.export": "/" } (qcow2)
^C (15.07/100%)
2. v2v will report error 'currently you must use ‘-of raw’' if reproduce the bug on rhel7, but v2v should report the error at the beginning, like step2 of comment3 of bug1607129
# virt-v2v -ic vpx://vsphere.local%5cAdministrator.73.141/data/10.73.75.219/?no_verify=1 esx6.7-rhel7.5-x86_64 -it vddk -io vddk-libdir=/home/vddk6.7 -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA -o rhv-upload -oc https://hp-dl360eg8-03.lab.eng.pek2.redhat.com/ovirt-engine/api -os nfs_data -op /tmp/rhvpasswd -oo rhv-cafile=/home/ca.pem -oo rhv-verifypeer=false --password-file /tmp/passwd -of qcow2 -oa preallocated
Exception AttributeError: "'module' object has no attribute 'dump_plugin'" in <module 'threading' from '/usr/lib64/python2.7/threading.pyc'> ignored
[ 0.5] Opening the source -i libvirt -ic vpx://vsphere.local%5cAdministrator.73.141/data/10.73.75.219/?no_verify=1 esx6.7-rhel7.5-x86_64 -it vddk -io vddk-libdir=/home/vddk6.7 -io vddk-thumbprint=1F:97:34:5F:B6:C2:BA:66:46:CB:1A:71:76:7D:6B:50:1E:03:00:EA
[ 4.3] Creating an overlay to protect the source from being modified
nbdkit: vddk[1]: error: VixDiskLib: VixDiskLibIsLegacyConnParams: the instance of VixDiskLibConnectParams is NOT allocated by VixDiskLib_AllocateConnectParams. The new features in 6.7 or later are not supported.
nbdkit: vddk[1]: error: VixDiskLib: VixDiskLibIsLegacyConnParams: the instance of VixDiskLibConnectParams is NOT allocated by VixDiskLib_AllocateConnectParams. The new features in 6.7 or later are not supported.
nbdkit: vddk[1]: error: VixDiskLib: VixDiskLibIsLegacyConnParams: the instance of VixDiskLibConnectParams is NOT allocated by VixDiskLib_AllocateConnectParams. The new features in 6.7 or later are not supported.
[ 7.2] Opening the overlay
libvirt needs authentication to connect to libvirt URI qemu:///system
(see also: http://libvirt.org/auth.htmlhttp://libvirt.org/uri.html)
Please enter your authentication name: test
Please enter your password:
nbdkit: vddk[2]: error: VixDiskLib: VixDiskLibIsLegacyConnParams: the instance of VixDiskLibConnectParams is NOT allocated by VixDiskLib_AllocateConnectParams. The new features in 6.7 or later are not supported.
nbdkit: vddk[2]: error: VixDiskLib: VixDiskLibIsLegacyConnParams: the instance of VixDiskLibConnectParams is NOT allocated by VixDiskLib_AllocateConnectParams. The new features in 6.7 or later are not supported.
nbdkit: vddk[2]: error: VixDiskLib: VixDiskLibIsLegacyConnParams: the instance of VixDiskLibConnectParams is NOT allocated by VixDiskLib_AllocateConnectParams. The new features in 6.7 or later are not supported.
[ 24.4] Inspecting the overlay
[ 43.1] Checking for sufficient free disk space in the guest
[ 43.1] Estimating space required on target for each disk
[ 43.1] Converting Red Hat Enterprise Linux Server 7.5 (Maipo) to run on KVM
virt-v2v: This guest has virtio drivers installed.
[ 128.7] Mapping filesystem data to avoid copying unused and blank areas
[ 129.2] Closing the overlay
[ 129.9] Assigning disks to buses
[ 129.9] Checking if the guest needs BIOS or UEFI to boot
[ 129.9] Initializing the target -o rhv-upload -oa preallocated -oc https://hp-dl360eg8-03.lab.eng.pek2.redhat.com/ovirt-engine/api -op /tmp/rhvpasswd -os nfs_data
virt-v2v: error: rhv-upload: currently you must use ‘-of raw’. This
restriction will be loosened in a future version.
If reporting bugs, run virt-v2v with debugging enabled and include the
complete output:
virt-v2v -v -x [...]
Comment 1Richard W.M. Jones
2021-03-16 13:56:03 UTC
(In reply to Xiaodai Wang from comment #4)
> Update about this bug:
>
> This is the latest test result of the combination of '-of' and '-oa'.
>
> -of raw -oa sparse not supported, see bz1600547
> -of raw -oa preallocated success on rhel8.6, failed on rhel9.1(bug?)
> -of qcow2 -oa sparse success on rhel9.1
> -of qcow2 -oa preallocated success on rhel9.1
>
> For the '-of raw -oa preallocated', Is it a new bug? It was success in
> RHEL8.6.
> https://libvirt-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/view/v2v/view/RHEL-8.
> 6/job/v2v-RHEL-8.6-runtest-x86_64-matrix-rhv_fc/1/testReport/rhel/
> convert_vm_to_ovirt/
> xen_vm_pv_linux_latest6_arch_x86_64_raw_f_FC_rhv_upload_rhv_direct_rhv_verify
> peer_preallocated_it_default/
Hi xiaodai, the problem you encountered should be bug 1939423 - V2V can't set '-oa preallocated' in rhv-upload conversion on rhel9
Comment 7Richard W.M. Jones
2022-06-14 09:32:55 UTC
I'm a bit confused about whether this is working or not on RHEL 9.1.
However the basic problem is this error from RHV (see the debug log):
ovirtsdk4.Error: Fault reason is "Operation Failed". Fault detail is "[Cannot add Virtual Disk. Disk configuration (RAW Sparse backup-None) is incompatible with the storage domain type.]". HTTP response code is 409.
Unfortunately there is no way for us to tell if particular combinations
will work, and RHV closed the bug where we asked them to provide that
information (https://bugzilla.redhat.com/show_bug.cgi?id=1829009).