Bug 193951 - x86_64 arch installs get packages duplicating i386 packages
x86_64 arch installs get packages duplicating i386 packages
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: rpm (Show other bugs)
4.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-03 00:43 EDT by Damian Menscher
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-26 15:26:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Menscher 2006-06-03 00:43:29 EDT
Description of problem:
# rpm -q --qf "%{NAME} %{ARCH}\n" hal
hal x86_64
hal i386

This causes confusion, like making admins wonder which version is on disk.  It
also confuses things like rpm -V, which doesn't know which database to compare
files against.  I recall (but haven't confirmed recently) that this also made it
difficult to remove packages, since rpm said multiple packages matched the name
you supplied (you had to specify arch also to distinguish).

I'm guessing the proper solution is to install *only* the x86_64 version, when
it is available, rather than installing the i386 version and then installing the
x86_64 version over it.  So perhaps this could be avoided with a patch to anaconda?

Version-Release number of selected component (if applicable):
rpm-4.3.3-13_nonptl
Comment 1 Paul Nasrat 2006-06-26 15:26:40 EDT
Anaconda and rpm is is performing correct multilib behaviour in choosing which
packages to install, if you chose compat arch support (selected by default)
you'll get those packages.  The rpm -V can be done as rpm -V hal.x86_64 of rpm
-V hal.i386.  


Note You need to log in before you can comment on or make changes to this bug.