Bug 193952 - RFE: fix spurious no-documentation warning on -devel subpackages
Summary: RFE: fix spurious no-documentation warning on -devel subpackages
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpmlint   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ville Skyttä
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-06-03 06:47 UTC by Hans de Goede
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-13 12:34:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Hans de Goede 2006-06-03 06:47:56 UTC
Hi,

For almost each review I do where there is a -devel subpackage I get the
following warning from rpmlint:
W: xxx-devel no-documentation

I would like rpmlint to not emit this warning for -devel subpackages (when
coding this better make that an array of possible subpackages for which to not
emit this, I'm sure once this is in people will think up other subpackages which
usualy don't have docs).

Comment 1 Ville Skyttä 2006-06-03 09:32:33 UTC
I don't see that warning as spurious, but rather a reminder to check if there
are some docs available that would be good to have included in the devel
subpackage, just like all other packages.

One warning per such a package isn't exactly an amount of noise that would make
it harder to spot other problems, so I'm inclined to leave this as is.  If
consensus says this is not good, I'll filter it out, but please initiate public
discussion somewhere (fedora-packaging list?) so the consensus can be heard.

Implementing this would be trivial, it's already done for -debuginfo packages
(which never contain documentation and there's nothing a packager can do about
that, so it's a different case), see /usr/share/rpmlint/config.



Comment 2 Hans de Goede 2006-06-04 05:09:25 UTC
I've send a mail about this to f-e-l as I'm not on f-p-l.


Comment 3 John Ellson 2006-06-04 13:32:28 UTC
Personally I'd like to see more man 3 pages for libraries.  Perhaps this warning
should be considered an error?

Comment 4 Hans de Goede 2006-11-13 12:34:01 UTC
Now that I'm a few months older and wiser, I think the warning indeed is just
fine as initially indicated by Ville, closing as not a bug.
+


Note You need to log in before you can comment on or make changes to this bug.