Bug 193954 - should have system group amavis
should have system group amavis
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: amavisd-new (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Pritchard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-03 05:17 EDT by Russell Coker
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-14 13:37:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Russell Coker 2006-06-03 05:17:10 EDT
Description of problem:

When a freshly installed system has amavis installed for the first time 
via "yum install amavisd-new" the group "amavis" will get GID 500 (which is 
not desired because system GIDs <500 should be used for daemons).  If 
amavisd-new is removed via "rpm -e amavisd-new" and then the user and group 
are removed via "userdel amavis" then a subsequent installation of amavisd-new 
will get a system GID for the group "amavis".

I can not repeat this problem with any other daemon package and can not get 
amavisd-new to do the wrong thing on a second install or the right thing on a 
first install.
Comment 1 Steven Pritchard 2006-06-14 13:37:27 EDT
Since bugzilla lost all this...

Bug #194725 was opened against openvpn for basically the same problem.

  Description of problem:
  openvpn package creates group openvpn with GID 500.
  It should use a system GID.
  
  Version-Release number of selected component (if applicable):
  openvpn-2.1-0.10.beta14.fc5
  
  How reproducible:
  Allways.
  
  Steps to Reproduce:
  1. yum install openvpn
  
  Actual results:
  GID of openvpn is 500.
  
  Expected results:
  GID of openvpn should be less than 500 (e.g. 103 in my tests).
  
  Additional info:
  
  Solution:
  openvpn rpm preinstall scriptlet should first add
  the group openvpn as a system group
  and then add the user openvpn.
  
  New rpm preinstall scriptlet:
  
  if ! id openvpn > /dev/null 2>&1 ; then
      /usr/sbin/groupadd -r openvpn
      /usr/sbin/useradd -r -s /sbin/nologin -c OpenVPN -d /etc/openvpn openvpn
  fi

Since this was actually a useradd problem, another bug (194728) was opened. 
Unfortunately, I don't have the full text of that bug, just the last couple of
entries.

------- Additional Comments From pvrabec@redhat.com  2006-06-12 08:45 EST -------
rawhide fix shadow-utils-4.0.16-2
------- Additional Comments From pvrabec@redhat.com  2006-06-12 11:31 EST -------
fc5 update shadow-utils-4.0.14-9.FC5

That bug was closed (RAWHIDE), and this bug and 194725 were closed as duplicates
of that bug.

Note You need to log in before you can comment on or make changes to this bug.