Bug 19396 - kernel rpm builds kernel for i686 even in .i386.rpm
Summary: kernel rpm builds kernel for i686 even in .i386.rpm
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
high
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-10-19 19:46 UTC by Michael Tokarev
Modified: 2007-03-27 03:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-30 21:34:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch for 2.2.17-4.spec (826 bytes, patch)
2000-10-30 21:34 UTC, Michael Tokarev
no flags Details | Diff

Description Michael Tokarev 2000-10-19 19:46:37 UTC
When on i686 machine I issue kernel build command, it will make all
kernels destined for the i686 regardless what said in config file
(kernel-2.2.16.i386.config etc).  I figured this out -- since
DependKernel() places RedHat's ..config to arch/i386/defconfig,
but changed by RedHat scripts/Configure looks to
configs/*-$KERNTYPE.config first (where $KERNELTYPE taken from
/boot/kernel.h), it will always got the configs for running kernel
instead of supplied config.

Suggested change is to place required config file to .config in
DependKernel instead of arch/.../defconfig (that isn't ever consulted
if configs/*$KERNTYPE exists).

What's interesting is that this should break all the kernels including
smp/BOOT etc -- all should be built using type of kernel running on
build machine...  I'm curious why there are no similar reports exists
in bugzilla.  Maybe I again missed something?

Note that this bug (if it is) is in 7.0 release also.

Comment 1 Michael Tokarev 2000-10-30 21:33:23 UTC
The same thing in latest 2.2.17-4 in rawhide.
People -- how you build different kernel rpms included in binary cdrom
etc ?!?!?!?
Patch for 2.2.17-4 included.


Comment 2 Michael Tokarev 2000-10-30 21:34:24 UTC
Created attachment 4794 [details]
patch for 2.2.17-4.spec

Comment 3 Michael Tokarev 2001-08-06 19:31:47 UTC
Well, this is very old issue, seems to be fixed a long-long time ago...



Note You need to log in before you can comment on or make changes to this bug.