Bug 193974 - sqlite package depends on compat-readline 4.3, but doesn't list it as dependency
sqlite package depends on compat-readline 4.3, but doesn't list it as dependency
Product: Fedora
Classification: Fedora
Component: sqlite (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Depends On:
  Show dependency treegraph
Reported: 2006-06-03 11:41 EDT by Jim Tittsler
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-06-26 13:52:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jim Tittsler 2006-06-03 11:41:55 EDT
Description of problem:

sqlite 3.3.3 depends on libreadline 4.3, but doesn't list it as dependency

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  install sqlite-3.3.3-1.2 without installing compat-readline43
2.  run sqlite3
3.  error message displayed about missing libreadline
Actual results:

Expected results:

Additional info:
Comment 1 Paul Nasrat 2006-06-26 13:52:33 EDT
How did you install? readline should be pulled in as a dep.  The only way I can
see this going wrong if you installed using nodeps.

rpm -qpR sqlite-3.3.3-1.2.i386.rpm  | grep readline

rpm -e --test readline 
        libreadline.so.5 is needed by (installed) sqlite-3.3.5-1.i386
Comment 2 Jim Tittsler 2006-06-26 18:56:20 EDT
Upgrade from FC3->FC5
Comment 3 Paul Nasrat 2006-06-26 19:29:37 EDT
Upgrade with anaconda? Please attach /root/upgrade.log, and reopen, other
upgrade methods are not supported although most depsolvers should have done the
correct thing.

Note You need to log in before you can comment on or make changes to this bug.