Bug 193988 - Latest upgrades of kernel and gcc don't match.
Latest upgrades of kernel and gcc don't match.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
5
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 194028 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-03 19:18 EDT by Nicola
Modified: 2015-01-04 17:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-10 20:41:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicola 2006-06-03 19:18:10 EDT
Description of problem:
Latest upgrade of FC5 of kernel and gcc don't match. Kernel is compiled with 
gcc 4.1.0, while current version of gcc is 4.1.1. Thus compiling external
modules is impossible.

Version-Release number of selected component (if applicable):
 gcc 4.1.1, kernel 2.6.16-1.2122_FC5

How reproducible:
Always

Steps to Reproduce:
1. Upgrade to latest kernel
2. Upgrade to latest gcc
3. Current gcc has larger version that the one used for compiling 
current kernel
  
Actual results:
It's impossible to compile external modules like the one
required from vmware.

Expected results:
To be able to use current gcc with current kernel.

Additional info:
This is not the first time it happens. Please make sure current gcc and kernel
match.
Comment 1 Jakub Jelinek 2006-06-05 02:32:59 EDT
*** Bug 194028 has been marked as a duplicate of this bug. ***
Comment 2 Jakub Jelinek 2006-06-05 02:36:27 EDT
That's kernel (or module utils) bug, it should never rely on the GCC patchlevel
version when doing matching compiler checks.  GCCs with different patchlevel
version, but the same major/minor version are compatible.

I don't remember anything like this being reported in the past where we changed
GCC patchlevel version many times during upgrades, so it must be a new
regression.
Comment 3 Dave Jones 2006-09-10 20:41:04 EDT
It doesn't. modinfo on any module will show the vermagic as "gcc-4.1".
It shouldn't make any difference at all what patchlevel gcc is used.

Note You need to log in before you can comment on or make changes to this bug.