Bug 1939887 - [ceph-ansible] : cephadm-adopt :conf file needs to be copied to alertmanager node inorder to adopt alertmanager
Summary: [ceph-ansible] : cephadm-adopt :conf file needs to be copied to alertmanager ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 5.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 5.0
Assignee: Guillaume Abrioux
QA Contact: Vasishta
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-17 09:36 UTC by Vasishta
Modified: 2021-08-30 08:29 UTC (History)
6 users (show)

Fixed In Version: ceph-ansible-6.0.2-1.el8cp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-08-30 08:29:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 6350 0 None open [skip ci] cephadm_adopt: fetch and write ceph minimal config 2021-03-17 10:13:27 UTC
Red Hat Issue Tracker RHCEPH-1198 0 None None None 2021-08-30 00:16:26 UTC
Red Hat Product Errata RHBA-2021:3294 0 None None None 2021-08-30 08:29:26 UTC

Description Vasishta 2021-03-17 09:36:08 UTC
Description of problem:
When cephadm-adopt playbook was tried on cluster with dedicated grafana node, plybook fails on grafana node while adopting alertmanager

Version-Release number of selected component (if applicable):
ceph-ansible-6.0.1-1.el8cp.noarch.rpm     

How reproducible:
Tried once

Steps to Reproduce:
1. Configure 4.x cluster with dedicated grafana node
2. Upgrade to 5.x
3. Run cephadm-adopt.yml playbook

Actual results:
stderr: 'ERROR: could not detect legacy fsid; set fsid in ceph.conf'

Expected results:
Playbook should succeed 

Additional info:

Comment 6 Vasishta 2021-03-24 15:39:46 UTC
Working fine with ceph-ansible-6.0.2-1.el8cp
Moving to VERIFIED state.

Comment 8 errata-xmlrpc 2021-08-30 08:29:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (Red Hat Ceph Storage 5.0 bug fix and enhancement), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:3294


Note You need to log in before you can comment on or make changes to this bug.