Bug 193989 - RFE/question: NTFS support
RFE/question: NTFS support
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-03 19:50 EDT by Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail}
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 17:29:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-06-03 19:50:23 EDT
I'd like to hereby reopen an already existing bug, which I can't due to
insufficient rights to someone else's bug. This has been already discussed in
bug #65749, which has been CLOSED as a WONTFIX.

I'm prepared for this to end up WONTFIX as well (though it would be great if it
didn't) but I'd like to get some more official comments on this from Red Hat as
the answers to questions already asked in the above mentioned bug were very
limited if any at all.

The document (FAQ -- answer to question 6.2) at URL
`http://wiki.linux-ntfs.org/doku.php?id=ntfs-en#how_do_i_convert_an_ntfs_volume_to_a_fat_volume'
says: `Red Hat always refers patents which don’t exist.' The only answer to this
was (bug #65749, comment #24): `After discussion with counsel, we deem the
inclusion of NTFS in the Fedora project to be too risky.  Patent encumbrance.'
So, please, could Red Hat be more specific on this issue?

Severeal other distros are being reported to include NTFS support without any
problems in this regard. Therefore a question arises if the patent concerns are
real? And as was stated in the mentioned bug, how does this differ from other
software that could be written only after successful reverse engineering (namely
samba and rdesktop)? (As for rdesktop I remember the developers expected RDP
protocol ver. 5 to be complicated due to patent and/or license issues as well.
But recently I read the new protocol version is supported as well.)

Thank you in advance for consideration and explanation.
Comment 1 Jiri TRAVNICEK, alias JITR {temporarily not reading bugmail} 2006-06-03 19:55:09 EDT
Sorry, the proper link to the FAQ document should have been
`http://wiki.linux-ntfs.org/doku.php?id=ntfs-en' or directly to the mentioned
part
`http://wiki.linux-ntfs.org/doku.php?id=ntfs-en#why_don_t_red_hat_fedora_support_ntfs'.

A preview beffore real bug submission would be nice but I guess this would be an
RFE to the Mozilla Foundation's Bugzilla...
Comment 2 Rahul Sundaram 2006-09-05 17:29:44 EDT

Dont confuse specific patent issues with generally acceptable reverse
engineering cases. Anyway this particular issue is already raised by me to
Fedora Advisory Board and we are waiting on counsel feedback on this issue. I am
closing this bug as we dont want to track this in bugzilla.

https://www.redhat.com/archives/fedora-advisory-board/2006-June/msg00100.html
http://interviews.slashdot.org/article.pl?sid=06/08/17/177220



Note You need to log in before you can comment on or make changes to this bug.