Bug 193993 - Can't exectue X11 apps in an ssh session with X11Forwarding enabled.
Can't exectue X11 apps in an ssh session with X11Forwarding enabled.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openssh (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-04 02:04 EDT by Gian Paolo Mureddu
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-06 04:04:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2006-06-04 02:04:07 EDT
Description of problem:
Starting an SSH session with ssh -Y user@server from any computer to FC5 results
in an inability to connect to the DISPLAY from the applications, as such failing
with a connection error. It does not matter if the server has in
/etc/ssh/sshd_config X11Forwarding yes and if the server is called with either
ssh -Y | ssh -X, the result is always the same.

Version-Release number of selected component (if applicable):
openssh-4.3p2-4
openssh-clients-4.3p2-4
openssh-server-4.3p2-4
openssh-askpass-4.3p2-4

How reproducible:
Always.

Steps to Reproduce:
1. Start an SSH session with either ssh -Y or ssh -X to an FC5 machine.
2. Try to execute any X application.
  
Actual results:
The applications return an error regarding an inability to connect to the
display, doing an echo $DISPLAY from within the SSH session returns:
localhost:10.0, but still the applications can't connect.

Expected results:
To be able to tunnel X11 protocol through SSH when explicitly set to.

Additional info:
Comment 1 Tomas Mraz 2006-06-05 04:07:30 EDT
I cannot reproduce this problem here. I don't think it is openssh problem.

What says rpm -q xorg-x11-xauth libX11 ?

What is exactly printed on console when you run for example xterm?

Do you have SELinux enabled?
Comment 2 Gian Paolo Mureddu 2006-06-05 21:44:57 EDT
Here's the output of rpm -q xorg-x11-xauth libX11:
xorg-x11-xauth-1.0.1-1.2
libX11-1.0.0-3
libX11-1.0.0-3

I'd assume this double libX11 is due 'cause I have FC5 x86_64.

Now this is odd... Yesterday, it did not work, today it works... I applied a
series of updates yesterday, I don't exactly remember which updates did the
system applied (ran pup mannually)... Did not reboot the system, only thing I
did was restart my session, and I did restart sshd after making the changes to
/etc/ssh/sshd_config.

Looking at /var/log/yum.log these are the updates applied:

Jun 04 22:34:07 Updated: alsa-lib.i386 1.0.11-4.rc2
Jun 04 22:34:09 Updated: info.x86_64 4.8-9.2.fc5.1
Jun 04 22:34:11 Updated: procps.x86_64 3.2.6-3.4
Jun 04 22:34:13 Updated: alsa-lib.x86_64 1.0.11-4.rc2
Jun 04 22:34:16 Updated: texinfo.x86_64 4.8-9.2.fc5.1
Jun 04 22:34:23 Updated: alsa-lib-devel.x86_64 1.0.11-4.rc2


SELinux is enabled set as permissive.

Thank you for the attention given to this, I guess is a non-issue, then.

Note You need to log in before you can comment on or make changes to this bug.