Bug 193998 - Add socket creation and ipccreate nodes to procattr api
Summary: Add socket creation and ipccreate nodes to procattr api
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Eric Paris
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords: SELinux
Depends On:
Blocks: FC6SELinuxKernel
TreeView+ depends on / blocked
 
Reported: 2006-06-04 06:45 UTC by James Morris
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-05 16:02:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description James Morris 2006-06-04 06:45:58 UTC
We need to implement socketcreate and perhaps ipccreate nodes (similar to
fscreate) in procattr API, so that these objects can be given specific
labels upon creation.  The socketcreate node at least is needed for inetd
and the new secmark controls.

Comment 1 Eric Paris 2006-06-20 14:35:09 UTC
sockcreate submitted.   I can't follow coding convention so I'm going to send
again.  Will move ipccreate to a new BZ not on FC6 blocker since I don't know
the use case that makes it required for RHEL5

Comment 2 Eric Paris 2006-06-28 16:57:42 UTC
sockcreate accepted into linus's tree for 2.6.18

http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=42c3e03ef6b298813557cdb997bd6db619cd65a2

closing

Comment 3 Eric Paris 2006-06-28 17:03:55 UTC
requires rework for sockcreate

Comment 4 Eric Paris 2006-07-05 16:02:39 UTC
actually closing this time.   197114 is for ipc create


Note You need to log in before you can comment on or make changes to this bug.