Bug 1940005 - GCP PD CSI driver does not have CSIDriver instance
Summary: GCP PD CSI driver does not have CSIDriver instance
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Storage
Version: 4.7
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 4.7.z
Assignee: Fabio Bertinatto
QA Contact: Chao Yang
URL:
Whiteboard:
Depends On: 1939865
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-17 12:24 UTC by OpenShift BugZilla Robot
Modified: 2021-05-19 15:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-19 15:15:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift gcp-pd-csi-driver-operator pull 18 0 None open [release-4.7] Bug 1940005: Add CSIDriver object 2021-03-19 01:01:12 UTC
Red Hat Product Errata RHBA-2021:1550 0 None None None 2021-05-19 15:15:57 UTC

Description OpenShift BugZilla Robot 2021-03-17 12:24:10 UTC
+++ This bug was initially created as a clone of Bug #1939865 +++

Description of problem:
GCP PD CSI driver operator does not create CSIDriver instance when installing the driver. All our CSI drivers should have one

Version-Release number of selected component (if applicable):
4.7.0

How reproducible:
always

Steps to Reproduce:
1. "oc get csidriver" on GCE

Actual results:
no instances

Expected results:
pd.csi.storage.gke.io is there

Comment 2 Chao Yang 2021-04-30 06:47:02 UTC
oc get csidriver
NAME                    ATTACHREQUIRED   PODINFOONMOUNT   MODES        AGE
pd.csi.storage.gke.io   true             false            Persistent   85m
[chaoyang@dhcp-141-216 ~]$ oc get clustercsidriver
NAME                    AGE
pd.csi.storage.gke.io   85m

4.7.0-0.nightly-2021-04-30-005443

Comment 4 Siddharth Sharma 2021-05-10 17:58:06 UTC
This bug will be shipped as part of next z-stream release 4.7.11 on May 19th, as 4.7.10 was dropped due to a blocker https://bugzilla.redhat.com/show_bug.cgi?id=1958518.

Comment 8 errata-xmlrpc 2021-05-19 15:15:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.7.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:1550


Note You need to log in before you can comment on or make changes to this bug.