Bug 194001 - RFE: GPT partition support (Intel Mac)
Summary: RFE: GPT partition support (Intel Mac)
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-06-04 07:49 UTC by Jurgen Kramer
Modified: 2007-11-30 22:11 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2006-06-18 10:01:07 UTC


Attachments (Terms of Use)

Description Jurgen Kramer 2006-06-04 07:49:05 UTC
Description of problem:
The current version of anaconda does not support the GPT disk partition used on
the new Intel Macs. This prevents using Fedora on these Macs

Version-Release number of selected component (if applicable):
Rawhide (tested with 06-Jun-01)

How reproducible:
Always

Steps to Reproduce:
1. Boot from current Fedora rescue / install CD
2. Anaconda warns about GPT partition and wants to erase it
3.
  
Actual results:
Anaconda warns about GPT partition and wants to erase it

Expected results:
Anaconda should be able to handle GPT partitions


Additional info:
Current versions of GRUB (0.97+) and parted are also required

Comment 1 Jeremy Katz 2006-06-04 18:37:42 UTC
We're supposed to be getting a few of the mactels this week -- once we do that,
I'll enable the support.  Right now, we don't allow GPT on x86 because most
boxes will then be left in a non-booting state.  So I want to do it in a way
that will avoid people ending up with non-booting boxes.

Comment 2 Jurgen Kramer 2006-06-06 19:35:22 UTC
OK, thanks. Any chance this will make it for inclusion in FC6t1?

Comment 3 Jurgen Kramer 2006-06-18 10:01:07 UTC
With the installer/recue CD from rawhide (17-Jun-06) I managed to install FC6 on
my MacBook succesfully!



Note You need to log in before you can comment on or make changes to this bug.