Bug 194001 - RFE: GPT partition support (Intel Mac)
RFE: GPT partition support (Intel Mac)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-06-04 03:49 EDT by Jurgen Kramer
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-18 06:01:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jurgen Kramer 2006-06-04 03:49:05 EDT
Description of problem:
The current version of anaconda does not support the GPT disk partition used on
the new Intel Macs. This prevents using Fedora on these Macs

Version-Release number of selected component (if applicable):
Rawhide (tested with 06-Jun-01)

How reproducible:
Always

Steps to Reproduce:
1. Boot from current Fedora rescue / install CD
2. Anaconda warns about GPT partition and wants to erase it
3.
  
Actual results:
Anaconda warns about GPT partition and wants to erase it

Expected results:
Anaconda should be able to handle GPT partitions


Additional info:
Current versions of GRUB (0.97+) and parted are also required
Comment 1 Jeremy Katz 2006-06-04 14:37:42 EDT
We're supposed to be getting a few of the mactels this week -- once we do that,
I'll enable the support.  Right now, we don't allow GPT on x86 because most
boxes will then be left in a non-booting state.  So I want to do it in a way
that will avoid people ending up with non-booting boxes.
Comment 2 Jurgen Kramer 2006-06-06 15:35:22 EDT
OK, thanks. Any chance this will make it for inclusion in FC6t1?
Comment 3 Jurgen Kramer 2006-06-18 06:01:07 EDT
With the installer/recue CD from rawhide (17-Jun-06) I managed to install FC6 on
my MacBook succesfully!

Note You need to log in before you can comment on or make changes to this bug.