Bug 194009 - Sounds fails on boot intermittently
Sounds fails on boot intermittently
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-04 10:24 EDT by James Rankin
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-07-08 22:30:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Rankin 2006-06-04 10:24:06 EDT
Description of problem:
I'm running FC5; it's fully up to date off the updates/extras/livna repos. When
I have to reboot the machine, sound fails about half of the time. When the sound
fails to work, I simply reboot again and that often, but not always, fixes the
problem.
I'm doing nothing to the machine at all from the time the sound fails to the
time it works, aside from clicking System | Shut Down and then Reboot.
I'm assuming this is an alsa issue, but really not sure. This problem has been
present for me for several versions of Alsa in FC5, but never once in FC4.

Version-Release number of selected component (if applicable):
sudo rpm -qa | grep alsa produces:
alsa-lib-1.0.11-4.rc2
alsa-utils-1.0.11-4.rc2
alsa-lib-debuginfo-1.0.11-4.rc2
alsa-lib-devel-1.0.11-4.rc2

/sbin/modprobe --list | grep alsa produces:
/lib/modules/2.6.16-1.2122_FC5/kernel/drivers/media/video/saa7134/saa7134-alsa.ko
/lib/modules/2.6.16-1.2122_FC5/kernel/drivers/media/video/cx88/cx88-alsa.ko



How reproducible:
An a machine with the CX88 driver, I'm assuming this problem should be
reproduced. I can't tell why it happens in the first place, since sound
sometimes works after boot, and sometimes doesn't. 

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Please let me know what other info I can provide... thanks!
Comment 1 Martin Stransky 2006-06-24 03:16:55 EDT
Please attach output of "amixer" utility when sound works and when it doesn't
(just after boot).
Comment 2 James Rankin 2006-07-08 22:30:34 EDT
Since upgrading to the 2.6.17 kernel, I've been unable to duplicate this
problem. Several reboots, both using kernel 2139 and 2145, have been normal with
sound working properly.
I've been keeping all packages up to date, so this may be coincidence... but
this problem has not happened again since moving to the 2.6.17 kernel.

Note You need to log in before you can comment on or make changes to this bug.