Bug 19401 - Red Hat 7.0 Installation crashes at final step
Red Hat 7.0 Installation crashes at final step
Status: CLOSED DUPLICATE of bug 18032
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-10-19 16:16 EDT by Reed White
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-19 18:00:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Reed White 2000-10-19 16:16:46 EDT
At the end of a custom installation, the installation process crashes, saying
"probable bug".  The crash seemed to happen at the point that the swap
partition was being formatted.

Below follows the data I entered during the installation, followed by the
error dump from just after the crash.

INSTALLATION DATA I ENTERED:

-. Insert CD1, boot up, and follow directions.
-@ Keyboard Model:  Microsoft Natural
-@ Dead keys: enable
-@ Mouse: MouseMan/GirstMouse (PS/2)
-@ Install Type: Custom System
-@ Manual Partitioning: Disk Druid, or fdisk
-. Disk Druid does not recognize swap partition (sees 92),
   so use fdisk to change swap partition sys ID to 82.
   Now Disk Druid recognizes the swap partition.
   Partitions: sda1 MSDOS             16mb  /msdos
               sda2 Linux (Caldera) 2094mb  /caldera
	 sda3 Linux (Swap)     133mb
	 sda4 Linux (RedHat7) 2094mb  /
 Partitions to Format:
-x /dev/sda4 /
-o /dev/sda2 /caldera  .Do not format this.
-x Check for bad blocks
 LILO Configuration:
-x Create boot disk
-o Do not install LILO  .Install LILO.
 Install Boot Record On:
-@ /dev/sda4 first sector of boot partition
-x Use linear mode
 Partition: /dev/sda1  Type: DOS/Windows:
-o Default boot image  .Not default boot image.
 Network Configuration, eth0:
-o DHCP
-x Activate on boot
-| IP address: 192.168.0.1
-| Net Mask: 255.255.255.0
-| Network: 192.168.0.254
-| Broadcast: 192.168.0.1
-| Hostname: alta1@localdomain
-| Gateway: 0.0.0.0
-| Primary DNS:
-| Secondary DNS:
-| Ternary DNS:
 Time Zone:
-x System clock uses UTC
-x Pacific Time
-x Use daylight savings time
-. Create "root" and "alta" accounts
-. Skip by authenticationconfig
-. Select software packages
 Video:
-| Horizontal Sync: 28-58
-| Vertical Sync: 55-110
-| Video Board: ATI Xpert 98
-x 8192K
-x Customize X Configuration
-o Use Graphical Login
-@ Desktop: Gnome
-x 24bbp, 1024x768
-->Next (to install)
 (Log is written to /tmp/install.log)
 (formatting /dev/sda4)
 (formatting swap)
 (INSTALLATION CRASH - probably bug)
 (Send to http://bugzilla.redhat.com/bugzilla)


ERROR LOG DUMP FROM AFTER THE CRASH:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in doInstall
    if self.method.systemMounted (self.fstab, self.instPath, self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 46, in systemMounted
    self.loopbackFile = mntPoint + fstab.filesystemSpace(mntPoint)[0][0] + \
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 258, in filesystemSpace
    space.append((mntpoint, isys.fsSpaceAvailable(topMount + '/' + mntpoint)))
  File "/usr/lib/anaconda/isys.py", line 16, in fsSpaceAvailable
    return _isys.devSpaceFree(fsystem)
SystemError: (2, 'No such file or directory')

Local variables in innermost frame:
fsystem: /mnt/sysimage//msdos

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>
Comment 1 Michael Fulbright 2000-10-19 18:00:47 EDT

*** This bug has been marked as a duplicate of 18032 ***

Note You need to log in before you can comment on or make changes to this bug.