Bug 194023 - Unrecoverable error: rangecheck in get
Unrecoverable error: rangecheck in get
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: ghostscript (Show other bugs)
5
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Mike McLean
:
Depends On:
Blocks: FC6Target
  Show dependency treegraph
 
Reported: 2006-06-04 23:25 EDT by Bob T.
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-06-07 07:09:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob T. 2006-06-04 23:25:48 EDT
Description of problem:  Most ghostscript commands fail with range check errors.


Version-Release number of selected component (if applicable):  8.15.2-1.1



How reproducible: Every Postscript file I've tried.


Steps to Reproduce:
1.ps2pdf something.ps or gv something.ps
2.
3.
  
Actual results:

Unrecoverable error: rangecheck in get
Operand stack:
      hrsyr.gsf    0





Expected results:
conversion to pdf or display

Additional info: The Postscript files I've tried work fine on ghostscript-7.07.
Comment 1 Bob T. 2006-06-04 23:27:16 EDT
Correction:  the product version number should be FC5 rather than FC4.
Comment 2 Bob T. 2006-06-05 07:21:02 EDT
Even gs by itself at the command line fails:

 % gs
 ESP Ghostscript 815.02 (2006-04-19)
 Copyright (C) 2004 artofcode LLC, Benicia, CA.  All rights reserved.
 This software comes with NO WARRANTY: see the file PUBLIC for details.
 CRIT: rangecheck in get
 Operand stack:
      hrsyr.gsf    0

However gs -h produces the usual output. The search path is as follows:

Search path:
   . : /usr/share/ghostscript/8.15/lib :
   /usr/share/ghostscript/8.15/Resource : /usr/share/ghostscript/fonts :
   /usr/share/fonts/default/ghostscript : /usr/share/fonts/default/Type1 :
   /usr/share/fonts/default/amspsfnt/pfb :
   /usr/share/fonts/default/cmpsfont/pfb : /usr/share/fonts/japanese :
   /etc/ghostscript



Comment 3 Tim Waugh 2006-06-05 07:34:27 EDT
What does 'rpm -q ghostscript-fonts' say, and also 'rpm -V ghostscript-fonts'?
Comment 4 Bob T. 2006-06-05 08:40:36 EDT
% rpm -q ghostscript-fonts
ghostscript-fonts-5.50-13.1

% rpm -V ghostscript-fonts

(no output) 

According to locate, /usr/share/fonts/default/ghostscript/hrsyr.gsf
is the only hrsyr.gsf on the system. 

I have the same issue on a second recently-upgraded system, but not on a third.
Comment 5 Tim Waugh 2006-06-05 08:57:57 EDT
What about 'rpm -V ghostscript'?  It seems like this file is only referenced in
/usr/share/ghostscript/8.15/lib/Fontmap.GS.
Comment 6 Bob T. 2006-06-05 09:17:28 EDT
% rpm -V ghostscript produces no output.  And I've rebuilt and re-installed
ghostscript from the src rpm with the same result.  I've also tried commenting
out the line with hrsyr.gsf in Fontmap.GS with no apparent effect.
Comment 7 Bob T. 2006-06-05 16:19:57 EDT
>It seems like this file [hrsyr.gsf] is only referenced in
>/usr/share/ghostscript/8.15/lib/Fontmap.GS.

There's a Fontmap in /usr/share/fonts/default/ghostscript that references hrsyr.gsf:

/                                        (hrsyr.gsf)

though without the FontName. If I add Hershey-Symbol as the FontName, the error
message changes to
  CRIT: rangecheck in get
  Operand stack:
      hrscso.gsf    0

that is, to the font referenced in the last line in the Fontmap *without* a
FontName. And so on.  Does every font in a Fontmap have to have a FontName?  
How does this Fontmap get generated?
Comment 8 Bob T. 2006-06-06 16:56:58 EDT
Does anyone have any suggestions on what I'm supposed to do with two Linux boxes
that don't have a working gs? Can rangechecks be disabled?
Comment 9 Tim Waugh 2006-06-07 06:02:53 EDT
Nothing in ghostscript creates that file that I am aware of.  I don't have a
Fontmap file there.

What does 'rpm -qf' on that file say?
Comment 10 Bob T. 2006-06-07 07:09:23 EDT
That Fontmap was created by the type1inst script.  When that Fontmap is removed,
ghostscript works.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.