Bug 194026 - subclipse does not work if subversion-javahl is installed
subclipse does not work if subversion-javahl is installed
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse-subclipse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Robert Marcano
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-06-04 23:32 EDT by Ben Konrath
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version: F7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 15:32:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Konrath 2006-06-04 23:32:04 EDT
Details are here:

https://www.redhat.com/archives/fedora-devel-java-list/2006-April/msg00039.html

Robert Marcano's Subclipse RPMs that are slated to go into extras have javahl
disabled as a temporary work around.
Comment 1 Frode Tennebø 2006-09-18 07:34:44 EDT
I'm not sure about the current status for this (as I find the Eclipse/javavm/
javac situation extremely confusion), but I ran into this exact problem just 
now (complete yum update as of 2006.09.18).

(from https://www.redhat.com/archives/fedora-devel-java-list/2006-April/
msg00048.html)

"As far the 'SVNClient class not found problem' goes, I noticed that this
only happens when the subversion-javahl rpm is installed. Maybe we can
mark the subversion-javahl rpm as a conflicting package for now and
carry on with getting this into extras. I think subclipse can work
without the javahl jar so we should be ok."

As I understand it javahl is required for file:/// access.  So, with regards to 
the last statement above, I believe it to be not entirely true (I might be 
wrong, though, but haven't found any workaround yet).
Comment 2 Ben Konrath 2006-09-19 09:11:48 EDT
(In reply to comment #1)
> As I understand it javahl is required for file:/// access.  So, with regards to 
> the last statement above, I believe it to be not entirely true (I might be 
> wrong, though, but haven't found any workaround yet).

Ok, I wasn't aware of this. I'll try to look into this soon. Thanks.

Comment 3 Andrew Overholt 2007-01-31 17:34:10 EST
Tom:  this is the subclipse issue we spoke about here:

https://www.redhat.com/archives/fedora-devel-java-list/2007-January/msg00013.html

Ben:  am I correct that this is the bug for this?
Comment 4 Ben Konrath 2007-01-31 18:06:11 EST
(In reply to comment #3)
> Ben:  am I correct that this is the bug for this?

Yes.

Comment 5 Robert Marcano 2007-02-06 15:26:44 EST
I tested the file:/// protocol and it is correct, if subversion-javahl installed
it fails. If I remove subversion-javahl package it still fails because subclipse
does not dynamically load javahl classes, it needs them.

If the subversion-javahl is installed but the JNI libraries are removed,
subcclipse is able to use SVNKit (currently packaged as javasvn, new package
waiting for review) to access the file:/// based repository. I will work on a
patch to disable the detection of the JNI libraries of the subversion-javahl package

For reference, Tom Tromey notified on the mailing list that a patch has been
added to GCJ in order to soon be able to enable native javahl

http://gcc.gnu.org/bugzilla/show_bug.cgi?id=29812

I am waiting for it to reach rawhide
Comment 6 Tom Tromey 2007-03-30 15:28:23 EDT
Just a quick ping -- the gcj patch ought to be in rawhide now.
Comment 7 Andrew Overholt 2007-04-02 12:49:36 EDT
 (In reply to comment #6)
> Just a quick ping -- the gcj patch ought to be in rawhide now.

I rebuilt the RPM without the patch and tested on my rawhide box and it works (I tested with both gcj and Sun on i386).

Sometimes I forget how much I love ssh keys and then I have to do password authentication for a bit and continuously have to copy and paste my password.

Thanks for fixing this, Tom!
Comment 8 Ben Konrath 2007-05-03 01:09:15 EDT
Robert, have you had a chance to rebuild subclipse without the patch?
Comment 9 Robert Marcano 2007-05-11 11:25:41 EDT
I have 1.2 ready to be uploaded still waiting for the review of Bug #227500 to
add svnkit to the repository (anyone can help?), If not I can just rebuild it
without the patch and wait for later for the 1.2 update
Comment 10 Ben Konrath 2007-05-14 00:29:27 EDT
Robert, you should post a message to fedora-devel-java-list to ask someone to
continue the review. I'm not a reviewer so I can't help. Sorry.
Comment 11 Jette Derriche 2007-07-16 14:56:22 EDT
I hope you'll bear with me, I have Googled and asked people on
linuxquestions.org, fedoraforum.org and the subclipse/subversion mailling list
with no luck. This is the only place I've seen anyone who is likely to know the
answer to my question.

I am using symbolic links in my subversion project, since this is the
recommended way of dealing with none-versioned data. SVNKit does not handle this
correct, but I am told at the subversion/subclipse maillinglist that JavaHL
honors the way that subversion deals with symbolic links. So I would like to be
able to select  JavaHL under "SVN interface".

As far as I understand, there is a problem with JavaHL and therefore it has been
disabled. Is there a reason to believe that it will be resolved any time soon?

Thanks :-)
Comment 12 Robert Marcano 2007-07-16 15:32:59 EDT
Comment(In reply to comment #11)
> As far as I understand, there is a problem with JavaHL and therefore it has been
> disabled. Is there a reason to believe that it will be resolved any time soon?

The patch that disables the JavaHL API, is not applied on F7, The problem with
using JavaHL still exists on FC6 because there are some classloading problems,
so a backport of GCJ is needed, I do not think that will happen anytime soon
Comment 13 Jette Derriche 2007-07-16 16:03:26 EDT
(In reply to comment #12)
> Comment(In reply to comment #11)
> > As far as I understand, there is a problem with JavaHL and therefore it has been
> > disabled. Is there a reason to believe that it will be resolved any time soon?
> 
> The patch that disables the JavaHL API, is not applied on F7, The problem with
> using JavaHL still exists on FC6 because there are some classloading problems,
> so a backport of GCJ is needed, I do not think that will happen anytime soon
> 

Thank you so much for the quick reply :-) It does not solve my problem here and
now, but at least I have some information to base my next move on... Thanks :-)

Note You need to log in before you can comment on or make changes to this bug.