Bug 1940263 - iwlwifi (AX210) stops working with linux-firmware-20210315
Summary: iwlwifi (AX210) stops working with linux-firmware-20210315
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: linux-firmware
Version: 33
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-03-18 00:21 UTC by Aleksei Bavshin
Modified: 2021-08-05 09:52 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-05-31 05:17:38 UTC
Type: Bug


Attachments (Terms of Use)
dmesg (76.23 KB, text/plain)
2021-03-18 00:21 UTC, Aleksei Bavshin
no flags Details
lspci -vv (20.21 KB, text/plain)
2021-03-18 00:22 UTC, Aleksei Bavshin
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Linux Kernel 212371 0 None None None 2021-03-21 13:10:12 UTC

Description Aleksei Bavshin 2021-03-18 00:21:46 UTC
Created attachment 1764240 [details]
dmesg

Description of problem:
iwlwifi (AX210) stops working with updated iwl7260-firmware package.
Downgrading to iwl7260-firmware-25.30.13.0-118.f33.noarch recovers wifi functionality.

Version-Release number of selected component (if applicable):
iwl7260-firmware-25.30.13.0-119.fc33.noarch (linux-firmware-20210315-119)
kernel-5.11.6-300.fc34.x86_64

Steps to Reproduce:
1. dnf upgrade iwl7260-firmware --enablerepo updates-testing
2. reboot

Actual results:
```
# dmesg |grep iwlwifi
[   13.797369] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
[   13.815353] iwlwifi 0000:02:00.0: api flags index 2 larger than supported by driver
[   13.815382] iwlwifi 0000:02:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 93.8.63.28
[   13.815869] iwlwifi 0000:02:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[   14.010140] iwlwifi 0000:02:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[   14.162457] iwlwifi 0000:02:00.0: loaded PNVM version 0x324cd670
[   14.265501] iwlwifi 0000:02:00.0: Timeout waiting for PNVM load!
[   14.265507] iwlwifi 0000:02:00.0: Failed to start RT ucode: -110
[   14.265514] iwlwifi 0000:02:00.0: iwl_trans_send_cmd bad state = 1
[   14.472502] iwlwifi 0000:02:00.0: firmware didn't ACK the reset - continue anyway
[   14.484659] iwlwifi 0000:02:00.0: Failed to run INIT ucode: -110
```
(full dmesg output is attached)

Expected results:

# dmesg |grep iwlwifi
[   16.037437] iwlwifi 0000:02:00.0: enabling device (0000 -> 0002)
[   16.047750] iwlwifi 0000:02:00.0: api flags index 2 larger than supported by driver
[   16.047778] iwlwifi 0000:02:00.0: TLV_FW_FSEQ_VERSION: FSEQ Version: 93.8.63.28
[   16.048271] iwlwifi 0000:02:00.0: loaded firmware version 59.601f3a66.0 ty-a0-gf-a0-59.ucode op_mode iwlmvm
[   16.236135] iwlwifi 0000:02:00.0: Detected Intel(R) Wi-Fi 6 AX210 160MHz, REV=0x420
[   16.457602] iwlwifi 0000:02:00.0: base HW address: 40:1c:83:3c:9c:81
[   16.530043] iwlwifi 0000:02:00.0 wlp2s0: renamed from wlan0

Additional info:

Comment 1 Aleksei Bavshin 2021-03-18 00:22:58 UTC
Created attachment 1764241 [details]
lspci -vv

Comment 2 Peter Robinson 2021-03-21 13:10:15 UTC
Looks like it may be a kernel problem (TBH not surprised, it iwlwifi seems to regress somewhere every kernel cycle)

Comment 3 Aleksei Bavshin 2021-03-23 18:30:23 UTC
I just had a chance to confirm something: the problem started with linux-firmware 20210315 and one of the differences for affected devices is addition of `%{_firmwarepath}/iwlwifi-ty-a0-gf-a0.pnvm.*`. Once I removed the file iwlwifi managed to initialize successfully.

The code for AX210 is new (IIRC the device is supported starting from 5.11) and I guess the part responsible for loading pnvm never worked. Or it wasn't tested outside of a few reference platforms that supposed to go on sale with this adapter. It's just that we haven't hit that code until the recent linux-firmware update.

Comment 4 Aleksei Bavshin 2021-03-25 02:16:57 UTC
Related discussions at Gentoo bug[1] and linux-wireless[2] suggest that the .pnvm files are not compatible with the stable 5.11 kernel and must not be shipped outside of rawhide.
5.12 will bump firmware API version to 62[3] and load the file in question successfully.


I think we should remove the file from f32-34 linux-firmware specs and maybe add a note that it is not to be added back until the kernel in stable releases is updated to 5.12.


[1]: https://bugs.gentoo.org/777324#c6
[2]: https://lore.kernel.org/linux-wireless/CAPiS6wCi2-cUaDkgkOFietb5Ko7oCLMjkoNcOfygNsSfYxAAeg@mail.gmail.com/T/#t
[3]: https://git.kernel.org/pub/scm/linux/kernel/git/next/linux-next.git/commit/?id=000735e5dbbb739ca3742413858c1d9cac899e10

Comment 5 James 2021-03-31 15:28:01 UTC
(In reply to Aleksei Bavshin from comment #3)
> I just had a chance to confirm something: the problem started with
> linux-firmware 20210315 and one of the differences for affected devices is
> addition of `%{_firmwarepath}/iwlwifi-ty-a0-gf-a0.pnvm.*`. Once I removed
> the file iwlwifi managed to initialize successfully.
> 
> The code for AX210 is new (IIRC the device is supported starting from 5.11)
> and I guess the part responsible for loading pnvm never worked. Or it wasn't
> tested outside of a few reference platforms that supposed to go on sale with
> this adapter. It's just that we haven't hit that code until the recent
> linux-firmware update.

I can confirm this. I just removed the file "iwlwifi-ty-a0-gf-a0.pnvm" and the wifi is initialized successfully.

Comment 6 Aleksei Bavshin 2021-05-31 05:17:38 UTC
5.12.x with the new firmware API has been available in all stable branches for a week or so. It's time to close the bug.

In my experience, iwlwifi driver from 5.12.x *requires* "iwlwifi-ty-a0-gf-a0.pnvm" to initialize AX210 so I recommend to restore the file or reinstall iwl7260-firmware before trying the updated kernel.

Comment 7 Jun Aruga 2021-08-03 19:21:26 UTC
> 5.12.x with the new firmware API has been available in all stable branches for a week or so. It's time to close the bug.

Anyone, can you updated "Fixed In Version:" field? Which RPM version of kernel or/and linux-firmware fixes this issue on Fedora 34 (and/or 33)? Thanks.

Comment 8 Peter Robinson 2021-08-04 16:56:52 UTC
(In reply to Jun Aruga from comment #7)
> > 5.12.x with the new firmware API has been available in all stable branches for a week or so. It's time to close the bug.
> 
> Anyone, can you updated "Fixed In Version:" field? Which RPM version of
> kernel or/and linux-firmware fixes this issue on Fedora 34 (and/or 33)?
> Thanks.

From comment 6: 5.12.x

Comment 9 Jun Aruga 2021-08-05 09:52:40 UTC
> From comment 6: 5.12.x

I just wanted to know which kernel RPM "5.12.n1-n2.fc34" or "5.12.n3-n4.fc35" version fixed the issue. But the info "5.12.x" is okay. Thanks.


Note You need to log in before you can comment on or make changes to this bug.