Bug 194029 - Providing alert message in Hardware Certification Interface
Providing alert message in Hardware Certification Interface
Status: CLOSED CURRENTRELEASE
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Hardware Catalog (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: XINSUN
Yu Shao
:
Depends On:
Blocks: 238477
  Show dependency treegraph
 
Reported: 2006-06-05 01:19 EDT by S. Lele
Modified: 2008-08-04 13:55 EDT (History)
6 users (show)

See Also:
Fixed In Version: 3.2rh-20080801.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-08-04 13:55:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch Fix: (1.14 KB, patch)
2008-07-13 22:46 EDT, XINSUN
no flags Details | Diff
Patch Improve: (1.22 KB, patch)
2008-07-17 04:44 EDT, XINSUN
no flags Details | Diff
Screenshot for the warnning message. (188.82 KB, image/png)
2008-07-17 04:45 EDT, XINSUN
no flags Details
Another patch for this bug. (883 bytes, patch)
2008-07-17 06:31 EDT, XINSUN
no flags Details | Diff
Patch Improve: (883 bytes, patch)
2008-07-22 03:11 EDT, XINSUN
no flags Details | Diff
The correct patch for review. pls ignore the patch which attach_id is "312311" (1.30 KB, patch)
2008-07-22 03:15 EDT, XINSUN
no flags Details | Diff
The screen snap shot for the warnning messages. (176.63 KB, image/png)
2008-07-22 03:18 EDT, XINSUN
no flags Details
Patch Improve: (1.27 KB, application/octet-stream)
2008-07-22 12:45 EDT, XINSUN
no flags Details
Patch Improve: (3.69 KB, patch)
2008-07-22 14:42 EDT, XINSUN
no flags Details | Diff
Patch Improve: (2.40 KB, patch)
2008-07-22 22:51 EDT, XINSUN
no flags Details | Diff

  None (edit)
Description S. Lele 2006-06-05 01:19:44 EDT
Description of problem:
Some times, it was observed that some of the important fields are left blank
e.g. Product Page URL. 
While submitting a new Hardware Certification request through
hardware.redhat.com, e.g. if "Product Page URL" field is left blank, then it
should alert with the "help" message like "Please enter Product Page URL OR
mention N.A. You may need to specify product specifications or attach product
specification sheet in the request".  
If Product Page URL or product specifications are not mentioned, then review
process could not be initiated. This will avoid delays causing due to lack of
information about product specifications


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Login to hardware.redhat.com
2.Click on "Create"
3.Then go to Product Page URL.
Presently, even if you keep this field blank and just attach the test rpm and
click "Continue", the request will be submitted. 
In this case, if "Product Page URL" field is left blank, it should alert with
the help message like "Please enter Product Page URL OR mention N.A. You may
need to specify product specifications or attach product specification sheet in
the request". 
  
Actual results:


Expected results:
If "Product Page URL" field is left blank, it should alert with the help message
like "Please enter Product Page URL OR mention N.A. You may need to specify
product specifications or attach product specification sheet in the request". 

Additional info:
Comment 2 XINSUN 2008-07-13 22:46:45 EDT
Created attachment 311676 [details]
Patch Fix: 

Add a piece of javascript to check the create cert form's "Product Page URL"
whether or not is NULL(leave blank). if "NULL",then pop up a alert dialog box
whose warning message is "Please enter "Product Page URL" or mention "N/A". You
may need to specify product specifications or attach product specification
sheet in the request". 

Above patch's solution is just an option for fixing this bug.
AFAIK,our catalog won't love the "pop-up" alert dialog box by javascript. if
so, I have another thought for fixing this bug: throw the user error which
means when vendor left the "Product Page URL" blank and summit, then throw a
user's error by the function "ThrowUserError("Miss Product Page URL")".

Rob, 
  please give me some suggestion.

Best Regards!
Nicho
Comment 4 XINSUN 2008-07-17 04:44:06 EDT
Created attachment 312013 [details]
Patch Improve:

Follow Rob 's suggestion: show the warning message in the "Verify
Certification" page. 

Pls review. 
Nicho
Comment 5 XINSUN 2008-07-17 04:45:43 EDT
Created attachment 312014 [details]
Screenshot for the warnning message.
Comment 6 XINSUN 2008-07-17 06:31:06 EDT
Created attachment 312029 [details]
Another patch for this bug.

This patch use another warning style for notice. its style is like the NOTICE
for "retiring the rhr package" in our catalog's index page.
Comment 7 Rob Landry 2008-07-17 11:27:13 EDT
Suggestion; instead of the top clearBoxWide, how about simply highlighting in
the summary section that no URL has been provided?  This could also feature
creep to go ahead and also highlight (again in the summary section where the
fields are) that make and model haven't been provided if they are the default
values.  So this bug could resolve a more generic missind data issue.
Comment 8 XINSUN 2008-07-22 03:11:00 EDT
Created attachment 312311 [details]
Patch Improve:

Fllow Rob's suggestion.
1.highlighting message "no URL has been provided" in the URL field when missing
URL.
2.highlighting message "Make hasn't been provided" in the Make field when
missing Make.
3.highlighting message "Model hasn't been provided" in the Model field when
missing Model.

pls review

Best Regards!
Nicho
Comment 9 XINSUN 2008-07-22 03:12:49 EDT
Comment on attachment 312311 [details]
Patch Improve:
Comment 10 XINSUN 2008-07-22 03:15:24 EDT
Created attachment 312312 [details]
The correct patch for review.  pls ignore the patch which attach_id is "312311"
Comment 11 XINSUN 2008-07-22 03:18:44 EDT
Created attachment 312313 [details]
The screen snap shot  for the warnning messages.

also can visit the http://bugdev.devel.redhat.com/hwcert-xisun2 to see the new
change for high lighting the missing data.

Nicho
Comment 12 Rob Landry 2008-07-22 11:56:42 EDT
The screen shot helps thanks, I think the language can be simplified to "(Not
Provided)" instead of the unique error messages; but otherwise looks good.
Comment 13 XINSUN 2008-07-22 12:45:39 EDT
Created attachment 312364 [details]
Patch Improve:

Simplified to "(Not Provided)" instead of the unique error messages
Comment 14 XINSUN 2008-07-22 14:42:00 EDT
Created attachment 312382 [details]
Patch Improve:

1.add js for when data source is changed to provide manually,change the default
to "Not Provided".

pls review 

Nicho
Comment 15 Rob Landry 2008-07-22 17:38:57 EDT
Testing on -xisun5 shows the change, but the (Not Provided) does not appear in
red and "model" ends up with no value on the verify page?
Comment 16 Rob Landry 2008-07-22 17:54:13 EDT
Actually we're going the wrong way, make and model should user error and tell
the vendor to do it again.  The URL can just display in red (Not Provided) on
the confirmation screen because on the 1st page it's prepopulated with http://
so (Not Provided) ends up meaning the same thing as a blank http:// marker.
Comment 17 XINSUN 2008-07-22 22:51:32 EDT
Created attachment 312412 [details]
Patch Improve:

1.Use ThrowUserError for Make and Model.
2.Add two UserError type.(missing_make & missing_model)
3.keep URL's part no changes.

The test link is http://bugdev.devel.redhat.com/hwcert-xisun2/enter.cgi

Pls review.
Thanks a lot 
Nicho
Comment 18 Rob Landry 2008-07-23 10:42:25 EDT
Looks good; please commit.
Comment 19 eric_liu 2008-08-01 07:58:20 EDT
tested and run good 

Note You need to log in before you can comment on or make changes to this bug.